Did anybody try to install mySQL on qnx 6.3 Neutrino? On … inary.html
Problem was in this line: scripts/mysql_install_db --user=mysql
It said that something is not found…

How can I install (step by step) mySQL on QNX 6.3 Neutrino?

I’ve installed MySQL on QNX 6.3. Of all the Open Software I’ve downloaded and attempted to install, this was one of the cleanest and most straight forward. If I were you, I would download the latest source, and post any problems you have getting it going.

Ok I’ll try. In fact I’ve already tried… QNX is completly new for me… Could you write me some guides how to install mySQL from source?

Other problem is network configuration…
I don’t know how to configure TCP/IP to make it work ;/
What and where should I write to make network run. (in other systems I use network with gateway

I don’t recall the specific details. I think it was different from the standard open source installation, which consists of running configure, make, and make install. There was a README file which explained what to do, and I recall it just worked. If you try that and run into problems, I’d be glad to help you through them.

In the menus under configuration there is a utility to setup your network configuration.

As far as TCP/IP goes, how you set it up depends on whether you want to connect to the internet or other network directly, through a router, or not at all.

If not at all, you would typically use 192.168.0 or 192.168.1 for the network address, although in principle you can use whatever valid IP you want.
If you are connected through a router, the router setup determines the gateway address. Typically in that case you use DHCP allows your nodes to learn the gateway address automatically along with the IP.

If you are not connecting to the internet through a router, then you probably have fixed IP’s, and in that case your ISP should provide you with your IP, gateway, and name server addresses. You might also have a special subnet mask to use if you don’t have a full class C network.

About network. It’s typical netwotk with adresses 192.168.0.x I suspect that my ethernet card doesn’t work correctly… “network is unreachable” always whatever i set in configuration.
How to check if my card is install properly? Should I install some special drivers (what drivers and how)? I have an integrated ethernet card.

Ok. I still can’t install mysql…
I am in /usr/local/mysql directory and i try to run mysql_install_db script as user “sql”
Result is in attached photo. Can anybody help me?

this ^M looks like Windows LF, there is an app converting to UNIX-LF

textto is the app

ok thank you very much. It’s working :slight_smile:

No I have some problems with compiling a C program under QNX…
On linux I simply did: cc mysql.c -lmysqlclient and it worked fine.
In QNX I have an error: /usr/qnx630/host/qnx6/x86/usr/bin/ntox86-ld: cannot find -lmysqlclient
collect2: ld returned 1 exit status
How can I simply compile my program?

Btw without -lmysqlcliet I have:
/tmp/cc8uuRtc.o: In function main': /tmp/cc8uuRtc.o(.text+0x28): undefined reference to mysql_init’
/tmp/cc8uuRtc.o(.text+0x4f): undefined reference to mysql_real_connect' /tmp/cc8uuRtc.o(.text+0x67): undefined reference to mysql_error’
/tmp/cc8uuRtc.o(.text+0x98): undefined reference to `mysql_close’
collect2: ld returned 1 exit status

I have intalled mysql in /usr/local/mysql

You need to tell the linker where to look for librairies. I don’t think /usr/local/mysql is in the search path, it wouldn’t make sense for the linker to look in every directory on the hard driver. Try adding -L/usr/local/mysql

I did:
gcc mysql.c -L/usr/local/mysql/lib -lmysqlclient
and still I have errors like:
/usr/local/mysql/lib/ undefined reference to ‘connect’

try to add -lsocket after your -lmysqlclient

Thanks for suggestion.
Basic problem was that I didn’t export my library path to LD_LIBRARY_PATH :slight_smile: Now it’s working :slight_smile: