Mounting filter module using io-net


I have written a very simple filter module for io-net but I am getting following error while I try to load it.

mount -vvvv -Tio-net

Parsed: mount from [] mount on [NULL] type [io-net]
exec: mount_io-net -o implied -o nostat /
Using internal mount (mount_io-net not found)
Type [io-net] Flags 0x80080000
Device [] Directory [/]
Options []
mount: Can’t mount / (type io-net)
mount: Possible reason: No such device or address

Please help me. I have tried my module with absolute path also i.e.

mount -vvvv -Tio-net /tmp/active/bin/

but it also gives same error.

Followng is the snippent that io-net will access.

static io_net_registrant_t filter_reg = {

static int my_filter_init(void *dll_hdl, dispatch_t *dpp, io_net_self_t *ion, char *options)
filter_dll_hdl = dll_hdl;
filter_ion = ion;
filter_dpp = dpp;

if(filter_ion->reg(filter_dll_hdl, &filter_reg, &filter_reg_hdl, NULL, NULL) == -1)
fprintf(stderr, "\nreg-ERROR ");
return (-1);


have you startet io-net already?

io-net &
mount -vvvv -Tio-net /tmp/active/bin/

if io-net already running, try:
io-net -i1 &
mount -vvvv -Tio-net /tmp/active/bin/

You also need to tell io-net, where is your enter function.

io_net_dll_entry_t io_net_dll_entry = { 1, myfilter_init };