QNX installation problem

I have a silly question, that I can not install QNX 6.2 to a computer, which is a quite old PC with 400mHz CPU. but I guess that might not be the real problem, hardware requirement for QNX should not be too high

the disk is fine as I can install to my office desktop, ofcourse it is high performance one, but when I tried to install it in the old one, it always stops at the second stage after it booted from the CD and copied all the files to the computer, then it shows everyhting I installed were unreleased, and I can not install other parts. the system can find packages in CD repository. but the install button is in grey colour

could you please give some suggestion? thank you

Maybe it didn’t find a HD to install on?

Boot QNX from your installing CD, and look in /dev, you should find /dev/hd0.
If not available then as Mario suggests your system can not find the disk.
If available, then use fdisk and delete the partitions, then install from scratch.

but I can login as root, and launch software installer. does this mean QNX has primarily installed?

the problem comes from the second stage, QNX even can read the CD and find what I need to install next, and I can choose or clear which package to install. the problem is all of the Install, Activate, and etc buttons at the top are in grey colur, and can not go on

During the installation the system prompts you with questions like( not sure how the exact text looks like ):

  • install from CD
  • install to harddisk.
    I have the feeling you installed from CD, but this does not install QNX on your HDD. It just boots QNX, brings everything in the memory but you can not use “Install” or “Activate” buttons.
    You should install to harddisk!

Koko, thank you for your kind reply, I double checked the installation process as you remind me to notice, it seems not the case you suggested. it prompts me to install from Cd or run from hard disk, I have to choose install from cd and followed what it prompts to partition and etc. it just did no good

I tried to fdisk the hard disk, still the same

this is really frustrating, as I have the same problem in another old PC, none of them work

I tried to install QNX6.3, it stuck at “hit esc for altboot … D”,


You never mentioned how big your hard disk is on this old system.

If you opted for a full install, it can take quite a bit of disk space (more than 1 gig), especially if your doing the momentics development suite.

It may be that the initial part of the OS installed and now your out of disk space to install the rest.


thank you, Tim,

the harddisk is 4GB, and 128MB RAM, should be enough for a full installation,

what is swap file? as it prompts “creating swap file, 128mb, you must have 256mb free space” while booting QNX after the first stage of installation.

strange, swap file was used in QNX6.2.X, but QNX6.3.X. This was a Linux flavour abandoned in 6.3

Hi, Koko, After boot from CD or QNX (the first part), I can find /dev/hd0, and be able to use fdisk to change or delete it, although I don;t know if thre is difference to partition using fdisk or partition the hard disk when install from CD

sorry, Koko, "swap file " prompt was when I tried to install QNX6.2, what is that, that 256MB free space means hard disk space or RAM? shall this cause any probelm?

I can not install QNX6.3 at all, it struck at “hit ESC for altboot…”, then display “D” and stopped

Does it stop during the installation or reboot after the installation?

when I try to install QNX6.3, it stops during the installation or before , as it does not begin to copy files

I had similar problem. The problem was in the RAM stick, especially with older system. Replace the RAM with reliable one and try again.