Another question, font problem

Hello again. I need your help another time.
I installed a qnx 6.3.0 SP1 without photon. The more single instalation that I could.

I have a problem with a spanish character “ñ”, instead of this character on the screen appears another thing.
Is there some way to change the language of the system?


P.D My English isn’t good, if someone needs that I explain something, please post it.

Well you may be a little on your own here. What you are asking for is a change to the fonts of the text mode of your video hardware. I don’t think QNX provides any support here, having put all their font support into Photon. On the other hand, this may be a standard VGA interface issue. I haven’t looked at this in a long time so I don’t quite remember. The original Monochrome and CGA hardware had fixed fonts that you could not change, however I think the EGA and VGA included a way to do this.

Hello, thanks for answer. My video hardware is a EGA/VGA card. Can you explain to me how can I change the fonts?
I didn’t find information about it.

Another time, thanks.

Here’s a place to start: … .htm#fonts

I read in qnx documentation that :

“You can also use the ISO-Latin1 supplemental and PC character sets for international characters”

I found in character sets in this document

that there is a way to enable ISO-Latin1 but I don’t understand how to do it.
Can someone help me?

It looks like you just need to use the right escape code. If that is not acceptable, you will have to look at the hardware again.

but how can I use the escape code? I don’t know which are the devc-con’s options to indicate the rigth escape code.

According to the documentation, GR {0xa0-0xff} defaults to G2.
You can specify that G2 is the PC character set by the escape sequence, ESC * U.
The character you want is 0xA4 in the PC character set.

If you want G2 set to the Iso-Latin set, you use the escape sequence, ESC * <.

I’ve never done this myself, but the doc you referenced is pretty clear.

Thanks for all