QNX 6.21 installation fail

When I tried to install QNX 6.21 on a computer I got this error:

“Unable to mount a qnx4 filesystem as /fs/hd0-qnx4 on /dev/hd/h0t79 (Corrupted file system detected) /.diskroot file for root not found on any filesystem
Starting with safe mode
Unable to locate fs-pkg”

What does this mean? And how can I get GNX installed on that computer?

Does this occur during setup before the system has been installed? If so, it might be a hardware error. Normally, when you try to install, you pick a partition to load into, after which the install program will dinit the partition and then attempt to mount it. It looks like the problem occurs at the mount stage.

Yes it does. When I press the spacebar I can try to force a partition, but that doesn’t work either. When I tried on a newer computer it said something about not having QNX 6.1 or something, and when I tried to force a partition it said there wasn’t 8 gigs of room on the computer, even though there were 45 free, is my CD bad or something?

I don’ think it is the CD. Is this possibly a serial ATA drive that you are trying to install on?

I have no idea, what if it was?

Well Serial ATA support for QNX 6.21 seems be a little spotty, at least if I can believe what I’ve read here. I think 6.3 support has improved.

If you can open the computer up it should be really obvious. Serial ATA drives have a relatively narrow ribbon cable. It looks like maybe 10 or so wires in it. Parallel ATA (as it now seems to be called) is a much wider ribbon. SCSI is even wider still.


If you do have serial ATA, you should go into the BIOS and enable legacy mode. This allows serial ATA to be compatible with IDE and often fixes the problem for QNX installs.


oooo, actually the only computer of mine that I haven’t tried installing QNX on has a SATA drive. The main computer I want it on is an old one, and definately not SATA. I tried installing it again, with forced partition. I get to where it starts to try to write to the harddrive but it ends up saying “Could not write to drive (input/output error)”