Q-NET over PPP connection

I start the ppp conection on server side:
pppd /dev/ser1 9600 netmask defaultroute updetach debug passive
And on the client side:
pppd /dev/ser1 9600 defaultroute
Then I mount Q-NET over IP
mount -T io-net -o bind=ip npm-qnet.so
But the directory /net is empty.

I have not personally used this arrangement, but I know someone who tried a few years ago.
I was unworkable!
Qnet ia actually quite a heavy weight protocol, the packet size ia about the same as for TCPIP.
So this has to me sent over the relativly slow 9600 of your serial line.
So it could just be that it takes a long time for qnet to do it’s node discovery.
Can you see activity on the serial line with a scope?

I am not sure if the “light weight” qnet protocol available in 6.3 is any better, but it might be worth looking at if you are running 6.3.

In the example mentioned above, my friend ditched the idea of qnet and implemented a simple serial protocol of his own, this was much more efficient and is very simple to implement.
Simple is usually best is it not?

Well, I know that qnet works over ppp. There is no node discovery on start up with ppp; to have nodes visible in /net directory you have to access some remote host like to try ls /net/myhost.
Also I tried qnet over serial line with devn-fd.so. It works fine and I didn’t discover any heavy weight overheads. It was reasonable for line set to 115200 baud, sligtly slower on file copying then Z modem. Though it was 6.1 and 6.2.1 time and I used devn-fd.so (fixed one from 6.2.1 setup), I believe devn-fd.so gives better performance than ppp. Maybe they added huge useless headers to qnet frames in 6.3, who knows (not that I believe they did).

115200/9600 =~ 12. If 115200 was “reasonable”, it could very well be that 9600 is not.