First time installing - Which one is it?

Hi everyone!

Another newbie here! Recently read about QNX on and got curious. I’m actually a Windows user but I’ve done some experimenting with NetBSD, but no other systems.

I wanted to try QNX and registered to get a key and then went to get the iso, but which one is it? All I found was versions of Momentics… Finally I downloaded and burned “QNX Momentics Development Suite 6.3.2 - Windows Host”.

When I tried to boot and make a fresh install with this CD I ran into problems (both in VMware and on an old machine). The boot process starts with “Hit Esc for .altboot …” but just keeps on adding dots. Nothing happens! What’s the problem? :frowning:

I just read in another post (dated 2006 something) that this is the wrong iso. The ones I should use are:
6.3.0-qnx-200405141702.iso → the OS and associated tools → the update to the Neutrino kernel → service pack 2

However, I can’t seem to find these on the webpage. Also, the one I downloaded (Momentics Development Suite) should include the QNX Neutrino RTOS according to the download page. So, which one am I supposed to use? …really confused! :confused:

Can’t see why it need to be this hard. Other systems usually have a “Download now” directly on the startpage, or at least not far away. But then again, I’m new in the QNX world :slight_smile:

Appreciate any help!
/ Mikael

“Windows Host” version, as far as I know, is ok if you choose to develop your programs in windows environment but to have them run you need a target machine (even a small/old one) running QNX, and to debug them the latter must be connected to the former by net or serial cable.
A simplest way to use the system, if you have a free disk or partition on your PC, is to install on it “QNX Neutrino Host” version, in dual boot with Windows in your case (I never tried virtualization softwares as VMware, so I’ll let it to others to comment, but I assume that even in that case you need “Neutrino host” version to install the target). After installing Neutrino, you have its desktop to play with, and possibly Momentics, so you have GUI development platform and target all in one. Be aware that the machine you run Momentics on needs quite a lot of RAM memory, that’s the reason you may want to run it on your newer PC as a Windows application (Windows Host) and the target (“Neutrino host” installation disk version) on the older one, but in this case only the old machine is running QNX and executing Neutrino applications (and there, maybe you have enough resources to run command line compiler etc. as an alternative).
If during installation on the old PC the boot process stalls, verify that “plag-and-play OS” option is set to false in BIOS.

That’s what’s happening… I’ve tried with “Neutrion host”-version as well, same thing!

I can’t find any setting in BIOS for “plug-and-play OS”, neither on the old machine nor on the VMware-machine.

So, am I using the right iso?

I tried installing again, with a little more patience…

Finally it stoped adding dots and the installation procedure went on without problems… it was just veeery slow :slight_smile:

So now I’m writing this from QNX on VMware :smiley:

Thanks for the help and sorry for this unnecessary thread!

I will most likely be back with other questions soon! :wink:

/ Mikael