USB mouse driver


can anybody tell me how I can start the USB mouse driver at startup (QNX 6.2.1 NC)?

The command I need to invoke is: “devi-hirun msoft fd -d/dev/usbmouse0 &”,
after starting USB controller, but it needs Photon to run first. I tried to configure the /etc/system/enum/devices/input file to ‘requires(@photon)’, but that doesn’t seem to work. I also tried to add a line to the config file that “tinit” uses → something like: usbmouse0 “devi-hirun msoft” qansi-m on, but that dowsn’t work either.

Any help would be greatly appreciated!!

Well, if you need invoke the command “devi-hirun…” I bet it is worth to read documentation (or even Usage message: ‘use devi-hirun’): … hirun.html

So, now you know that devi-hirun is started by inputtrap utility. Next step is reading documentation for inputtrap: … ttrap.html

You have all documentation locally, just click Help on the shelf. There are examples provided in documentation also.

Best regards,

Thanks ed1k…

I did read the help, but the trapfile didn’t work either at first. Then I realized that the inputtrap command cut off the last character of my trapfile, thus the USB mouse driver didn’t load correctly. A few carriage returns did the trick…

Thanks for your help…

Hi stud5

You seem to have solved/fixed the problem I am now facing.
But I’ve now read the files. But not sure how to invoke “inputtrap”.
Also cannot find hotkeys for invoking anything inside QNX once it starts - with the exception of Print Screen. Argh!!!

Sorry to be such a newbie.

If I remeber correctly inputtrap is started automatically. But I can’t remember what the hotkey is to open a console window. I attached the input.localhost file that I used…It should work for you if you put it in the directory mentioned earlier…

Maybe you should first try to invoke the “devi-hirun” command from a shell to see if it works…


Could not attach the file. The extension is not allowed in this forum. I guess you have to copy and paste:

ps2 mousedev
kbd fd -d /dev/kbd
msoft fd -d /dev/usbmouse0

for attachment, it accepts .gz or .zip extension, so if you compress your file, you should be able to upload.