Can't log in


I’m totally new to QNX. I recently connected a PC104 to run a program on it. After connecting back to my desktop, a pop up window appear that says “new video card detected”. There is no other option other than the 640*480. After chossing ok, I am not able to log into QNX.

All i did was disconnect the power and cable of the hard disk and transfer them to the PC104. Then i connected the monitor and mouse to the PC104. After running one program, I connected the desktop as before.

Can anyone kindly help me out here?

I’m not sure what you mean by you can’t log in.

Do you mean you don’t see the Photon login screen?
Do you mean that the mouse and keyboard aren’t working?
Do you mean the username and password aren’t working?

It sounds like your not getting the photon login. Probably because the driver selected for the PC104 isn’t supported on the desktop. Any chance you have networking running on the QNX machine and can telnet in (you’d need to be running inetd)?


I get into the Photon login screen only after choosing ok on the ‘new video card detected’ dialog screen.
My mouse and keyboard is still working as i am able to type root and password into the login screen.

But after clicking enter, the screen goes blank. The moment i move my mouse or press any other key, the login screen reappears.

Thanks for your kind assistance.

If you connect the harddrive back to the PC104 board along with the monitor/keyboard/mouse, can you login there?

If all you did was run one program it seems unlikely that you’d lose the ability to login unless your one program changed the password file in the /etc directory.

I am wondering if something went wrong with photon when the graphics driver got changed that prevents you going past the login screen. Hopefully once your back to the PC104 board you’ll be able to login again.


Unfortuantely i couldn’t try what you suggested. The QNX is on a shared desktop in a lab. And some other people had tried re-installing qnx. Right now, we are able to re-install qnx, but while trying ti install momentics, we encounter the error:
“Error During Load”
Details: During extraction of /fs/cd0/rep621/ph-vpim-2.0.4-x86-qnx.qpk
Repository: Professional Edition V6.2.1

Then when i ignore this error and continue, I encounter the next error:
Error: Package Error
Details: QPK extraction failed
Package: QNX Photon Japanese Input Method 2.0.4 (x86)

Then after i continue, it says installation failed.

What could be the problem here? Could it be due to a faulty cd?
Thanks in advance


It’s either a CD error or a harddrive error.

I’d take the CD and wipe it clean with a cloth and make sure it’s not scratched. Then I’d try again.

If it still fails you’ll either have to try another CD or another harddrive to determine which one is giving the error.


To your old problem:
You can have a rescue shell opened during boot before photon and can setup to NOT START PHOTON. This means you can manually initialte photon (by typing ph) and see if there are some errors.

“But after clicking enter, the screen goes blank. The moment i move my mouse or press any other key, the login screen reappears” This seems like shelf is missing or whatever you try to run after login, if nothing is running you are logged of automatically again → reappearance of the loginwindow

To the new Problem
As Tim suggested i also guess on CD/HD error, but it may be a RAM-Error too. Best to test, get another CD and check, if it fails, get another HD and check, if this fails get another RAM. If this fails shoot yourself in the foot ^^ – if this fails im out of options right now :stuck_out_tongue_winking_eye:

Problem solved. Its a CD problem.