Another QNX 3.21 problem - erratic mouse

I don’t have a clue about QNX, but I’ve inherited the job of building a backup machine for the machine (starting to sound like a coffee grinder) that is currently running all the HVAC systems for several of our buildings. This is an old Barber-Coleman system that isn’t supported anymore. I’ve managed to get everything loaded and the DB imported and everything works fine except the mouse. It moves but it is so erratic you can’t control it and none of the buttons work. I’ve tried every kind of mouse I can think of, and even unplugged the one that works on the existing machine and plugged it into the new machine and it didn’t work, same symtoms. I can’t find any mouse file in QNX 3.21 is it named something else, or does anyone have any ideas what could cause this, if I could just get the mouse to work right we would have a gloden backup machine for when the HD finally crashes. I only have the documentation for the Barber-Coleman software and it doesn’t cover much about QNX.

NAB :slight_smile:

For starters it may be useful to compare the output of ‘mount’ and ‘tsk’ between a working and non-working system.

When you say ‘mouse’ I must ask, are you running QNX Windows on this system. If not, tell us more about the use of the mouse. Is it functioning in text mode? Also, what kind of mice have you tried? Serial, PS/2, one of the really old Microsoft mice that needed its own ISA card?

A rough guess at this time might be that you are having a hardware interrupt problem. If you know how to, you might want to check whether there are any interrupt conflicts. If it is a serial mouse, and you know how to shut down the mouse driver, you can run qtalk on the serial port and see if the data comes in erratically.

You might also want to say something about the cpu you are running on. If it is a post 486 processor, there are all sorts of hardware problems that might crop up.

The machine is a Compaq 486/33i with 16 mb ram. I run mount and I can see tty3 = $mdm serial at 03f8 far as I can tell that is the mouse because when in the Barber-Coleman host system setup screen it shows $mdm as the mouse on serialA. I also think it might be some kind of IRQ conflict because it sure acts like it, the cursor moves when you move the mouse but it is very erratic and none of the buttons work, I’ve seen that B4 when there was an IRQ conflict. If I run TSK I don’t see anything relating to $mdm or serial or anything I recognize as maybe relating to the mouse. I think all the hardware is good because before I choose this machine to use it had a fully functional Win 3.1 install on it and I made sure a serial mouse worked on Com 1 everything worked fine. I don’t think this Barber-Coleman stuff is QNX windows, it resembles the old DOS shell screens, no icons or graphics, just boxes you can tab to and text based screens. The BC system also requires that you make a DOS partition and load PCDOS 4.0 but the QNX partition is the bootable/active partition. Any thoughts or ideas would be greatly appreciated, I keep banging my forehead against the wall and it’s starting to hurt.

NAB :slight_smile:

The machine is a Compaq 486/33i with 16 mb ram.

Good, this is the right vintage.

I run mount and I can see tty3 = $mdm serial at 03f8 far as I can tell that is the mouse because when in the Barber-Coleman host system setup screen it shows $mdm as the mouse on serialA.

Since you know how to run mount, you know how to get to a $ prompt, so you might want to run “$ qtalk” and move the mouse around. Qtalk is a terminal emulator, and the secret key is CTRL-A. You will need this key to quit. The tty might by default be in EDIT rather than RAW mode. The stty command will show or turn off/on options as follows:

$ stty <$mdm (look at options

$ stty -edit -igate >$mdm

You want to try this in raw mode. You can also change the baud rate parity and stop bits with this command. Try "$ stty ? to get the whole picture.

With the mouse moving, you should see a steady stream of data. If the stream is erratic, then that suggests some kind of hardware problem, possibly an interrupt conflict. If not, it suggests a software problem, probably in the task that is reading the port. Why this might be a problem is not at all clear.

An IRQ conflict while possible, is a little unlikely. $mdm is no doubt on IRQ 4, and only another serial port card is likely to try use that port. A more likely possibility is that the IRQ isn’t firing at all. Assuming the driver is hooked to the timer interrupt, it might only be checking the serial port every 1/20th of a second, which could cause the erratic behavior.

Didn’t some mice of that vintage (like Mouse Systems mice) use their own boards that looked a lot like serial ports to software but didn’t quite work exactly like standard serial ports? Another thing is that there was no standard QNX mouse driver back then until QNX Windows was released.

Thanks for the help - when I run qtalk I do see steady stream of data when moving the mouse around and I can see the parameters on the port now with the stty command - first thing Monday I’m going to go and compare what happens on the running system and see what stty shows it is set up for - this is great help - thanks a lot and have a great weekend

NAB :slight_smile:

This could be the worst outcome. The software (the application software) is getting confused by the mouse input. I guess you have to find a mouse it likes, as from your description, you have no chance of fixing the software.

You were exactly right - I had to just keep trying different mice until I found one that it liked, I finally found an old pre Windows 95 CLIX Model CX-30 3-button serial mouse that works perfectly. I must have went through 15 different mice of all types - no luck then one of our guys here found this one in his junk box and brought it here and it worked. From all I’ve read it has something to do with something called Vmouse that started with Win95, so it has to be a 3 button mouse that was made prior to Win95, none of the newer 3 button serial mice I tried would work, nor would any PS2 mice or any bus mice.

NAB :slight_smile: