Tried using Net.rtl with PCI card RTL8139D but nettrap doesn’t recognise it.

I have tried this with different cards of the same vintage with the same result.

I have 4.25G and the latest updates, also the QNX site suggests that this chip is supported.

When I try a RTL8139B it works without any problems.

Any ideas?

We use cards with different 8139 chips and also 8100 chips. They always work. Run

Net.rtl -v &

If you still have problem, show your sysinit, output of show_pci and MoBo name.


I’ve tried running

Net.rtl -v &

but it returns with:

DriverInt: Unable to locate adapter

The network card I have installed is:

Dynamode NC100TX-DL Realtek 10/100 Network Adapter, which has the 8139D onboard. I have just removed a card with the 8139B chip and that worked fine.

Any ideas?

Realtek RTL8139D based 10/100 Ethernet adapters work fine with Net.rtl under QNX4.

Try to type show_pci QNX should “see” the Ethernet adapter. If not, there is some HW problem or the card hasn’t 8139D standard behavior.

On some PC I had problem with Ethernet PCI card in certain slot. Try PCI slots 1 to 4.

Is the 8139D card OK? Try it in windows PC.

Oooops: I have HP Compaq dc5800 (AM531AW#AKR) PC with one PCI slot and QNX 4.25 “Net.rtl -v” cannot “see” PCI RTL8139D cards (two new 8139Ds from various manufacturers) - “Unable to locate adapter”.

PC also has integrated (Intel Gigabit Net.e1000) Ethernet NIC - it works OK under QNX 4.25. But I need two networks.

Show_pci detects both Ethernet adapters OK (integrated and RTL8139).

Old 10mbit (Net.ether1000) card works OK in that PCI slot.

Could be there some specific problem with the HP dc5800, some critical BIOS Setup setting or need to specify some additional parameters to Net.rtl driver?

Have you any ideas?