qcc problem of target

I need to port Libpacap on QNX so I downloaded (on the community site of QNX) the sources of io-pkt. Io-pkt replaces more efficiently io-net, in particular it ensures the compatibility with Libpcap.
But when I try to compile its sources with
qcc -Vgcc_ntox86 -c …assptinf.c
I get the message
unknow target ‘gcc_ntox86’
no targets defined in etc/qcc
What does it mean?

It means that gcc_ntox86 is not a valid option.

You need to use an option like

qcc -V3.3.5,gcc_ntox86_cpp

Use qcc -V to see all the valid option for qcc.


Tim, I think the problem is bigger here. It looks as if the OP either doesn’t have the conf files present on their system (i.e. -Vgcc_ntox86 should be valid, as it is not necessary to specify the version if you want the default), or they haven’t got the QNX_TARGET/QNX_HOST envvars set correctly…

Thanks for your replies. I think you’re right. Since I have had many problems with this installation of QNX, I think I should juste reinstall it. Furthermore, I read the syntax of qcc in the qnx site and it seems it is indeed not necessary to specify the version. So I’ll just try that.

The default version is 2.9.? so if you want to use 3.3.5 either you make it the default version qcc -V3.3.3,gcc_ntox86 -set-defaults or you specify the options each time.