I♥QNX in file system


On our QNX4.25 system, the other day I was unable to use pipe “|” (as in sin|more). When I did, it seemed to try to execute every file in the directory I happend to be in.

Now many of the directories have what looks like a binary file called I♥QNX. Looks like the file system is messed up. What is going on? Any help is appreciated.


Hello Dan,
What was the exact command that caused the problem? Was it just sin|more? Is the problem reproducible?
As to the file system being messed up, try to fix it with chkfsys.


Thanks for responding.

It seemed to happen when I used pipe “|”. For example “sin|more” or “sin|less”. It was OK when using sin by itself.

Hello Dan,
Can you post (attach) one of the files with this strange name?

Hello Yuriy,

I ran chkfsys and that fixed all the file problems. Everything looks normal and the I♥QNX files are gone. However, the pipe “|” thing is still a problem.

I can do ls, sin, cat, but when I try to use | it looks like it starts to execute each file in the /bin directory because I see on the display:

… :not found
.best: not found
Audio: card type not specified
Blkfsys failed to attach name: Resource busy

If you ls the /bin directory, the first few entries are


So it appears that it’s trying to execute each file that it finds.

Hello Dan,
Try the following:
On console 1:
ls –lR /usr | more

On console 2:
sin –P Pipe

Do you see something like
21 //1/bin/Pipe


Hello Yuriy,

I’ve solved the problem. It wasn’t pipe at all. It was “more” and “less” executables in /bin. They were overwritten with directory information. Once I copied more and less from another node everything was fine.

Thanks again for your help,

The I♥QNX is a file system marker that’s helpful if you really mess up a disk and want to try to put it back together. It is in a part of the disk that you should never see unless you are looking directly at /dev/hd0t77 or /dev/hd0.

I have seen more corrupted before. Someone mistakenly types “ls > more” instead of “ls | more”, and instead of piping to more, the more file gets overwritten.
Just need to be aware.

Reply to MSchneider:

Funny that you mentioned "more geting corrupted. That’s exactly what happened. I was training someone on Monday and that is precisely what he typed by mistake.

“ls > more” which, of course, wrote the listing of /bin into the file “more”. Then to add to the confusion, he also typed “ls > less” so that one was corrupted as well.

Thanks to everyone for responding.


Sounds like a good reason not to train newbies by using the root account ;-)


Look in root directory. There’s file “pipe”.
If there isn’t pipe don’t work.
This file makes with /bin/Pipe utilite.
Put in sysinite next string to run it:
Pipe &