sshd crashes/exists from time to time


The sshd on my qnx crashes/exists from time to time. (I cannot see it with pidin). I need to restart sshd to continue working.

This is annoying because I need to run program remotely. Connection lost may cause hazards.

The qnx version is 6.3.0+sp2.
The openssh version is OpenSSH_3.7.1p1

Any idea what happens? Is it a known problem?


Hello Yyd_iris,
Are you starting sshd with inetd?
If so, try starting it directly, something like

Hi Yuriy

I start /opt/sbin/sshd directly in /etc/rc.d/rc.local


I have a similar problem, I start my sshd from rc.local and during boot I see a msg saying “PRNG not seeded”
But I did start the random -t before and waited for /dev/random before staring sshd. anyhow after it boots, I start sshd manually and it works. What gives?
Also if I start sshd from phapps file instead of rc.local, it works fine too.

How long do you wait?
Try 5 seconds.

Could this have anything to do with “pipe”? If so, download the latest source and compile. There’s a probably with pipe that causes a problem with anonymous ftp, and I’m wondering if it could be related to your problem.

sleep 5
works but I don’t like it. Just bothers me why sshd complains PRNG not seeded as if random service has not finished loading it self. If you slay random after boot and try running sshd, you get the same error msg. This tells me that for some reason random service is not fully loaded when sshd is executed but I also tried waitfor /dev/random and it still didn’t work. Just strange…