problems with tar and samba

I feel like such a fool asking such stupid questions but I’ve searched for the last 4 hours and got not very far.

Basically I want to be able to share files across my LAN with two other (windows) PC’s so I followed all the instructions for downloading and installing samba. Then I tried to mount a network hard drive using /usr/sbin/smbd but didn’t really know what was gong on. So I looked online for help and read the samba documentation which talks about editing the smb.conf file. I couldn’t find this anywhere. I also followed instructions on setting up SWAT. But when I try and access it from voyager typing localhost:901/ I get ‘can’t find the host’ type error.

How can I set samba up so that I can access the shared folders on my networked Windows machines?

Also I downloaded a gui app for samba so that I could access the shared resources through a gui (and possibly get help with configuration!) but it is in a tar.gz package.

Now, I have succesfully un zipped it using gzip -d filename and now i have just .tar file but I have spent hours trying to extract the package. I’ve tried tar -x filename and most other things but all that happens is that the terminal moves to the next line, loses the # and doesn’t respond to anything else. The thing is I don’t know what is actually meant to happen here. The CPU monitor shows no activity so I assume it isn’t processing.

Please can you help me. I feel like such an idiot, not eing able to do somethign as basic as un tar a file. Are there any software apps to handle gzip and tar files? I couldn’t find any.

Thanks for any help


I don’t know much about Samba, basicly if you need access to other shared folders you can use fs-cifs … -cifs.html
but if you need other way around, i.e. make available for other hosts some directory(ies) on QNX box, you probably need install Samba. Not so far ago there was good discussion about Samba on newsgroups, check out nntp:// qdn.public.qnxrtp.* newsgroups and comp.os.qnx
Or make search here

As for tar … t/tar.html
Or shortly
$ tar -xzf archive.tgz
$ tar -xzf archive.tar.gz
$ tar -xf archive.tar
I hope it helps.

Thanks. I successfully un tared my file. I now have an executable file and an install text document saying “just execute this file”. I have tried executing it using exe but it tells me that it is a directory not a file. If I try to cd to it though it tells me it is not a directory. Surely it shouldn’t be so hard to execute a file?

I tried using fs-cifs like so:

fs-cifs //MULTIVISION:SMB_SERVER:CDrive /mnt guest \ none

and got:
io-mount: No Error
fs-cifs: missing arguments, or all mount attempts failed

all the arguments there should work and I followed the examples in the documentation.

I also tried:

fs-cifs &

mount -t cifs -o guest,none //MULTIVISION:SMB_SERVER:CDrive /mnt

but got:

mount: Can’t mount /mnt (cifs)
mount: possible reason: bad file descriptor

I tried using /bin, /fs, /, and other custom names but always got the same error.

Can anyone help?

Thanks again.

Hi banks,
There are two situations where u can use fs-cifs (Atleast I’m aware of these two)
a)Between two QNX machines connected on lan
b)One Qnx HOSt having SAMBA server running and other is win machine . Both are on LAN.
Here we can access some share directories from win host to qnx provided that windows machine
has given proper access for share folder.
Example: On Win host u have share folder called “ShareFolder” and access are given to user
“guest” which is having password “guest”

     then from qnx host u can try

fs-cifs -L P_address_of_WIN_machine:WIN_MACHINE_NAME:/ShareFolder /ShareAs guest
which will ask u for password and on right password it will mount the shareFolder on Qnx Host

Now coming back to your problem solution try doing following steps

There are few steps you have to follow before u start accesing folder from QNX HOST to WIN PC
1.Make sure that “smbd” and “nmbd” processes are running before u try accessing any share folder from qnx Host to win PC.

These processes will be present in /opt/sbin/
If not started already, start it as follow from shell

/opt/sbin/smbd -D
/opt/sbin/nmbd -D

once these processes are started

  1. Add user(who can access folder from QNX host on win machine) on samba server using
    smbpasswd -a username password

2.Make sure that Directory which you want to access on win PC have its entry in smb.conf file
This file will be there in /etc/samba directory.

You can add entry as follow

	path = /usr/username
	valid users = username
	writable = yes
	create mask = 0777
  1. MAP QNX host directories from WIN PC
    example : \IP_address_of_QNXmachine_running_SAMBA\ShareFolderName\

prashant :slight_smile:

Thanks for the help there.

That last point is my main problem. - I don’t have a samba folder in /etc/. in fact I don’t have the smb.conf file any where on my machine. I installed it from the qssl 3rd party repository online and I can run smbd processes but I don’t have a configuration file any where. I guess I could try the install again but the software installer does claim that samba is installed.

I was wondering in qnx used samba differently because I read the samba docs about the conf file and tried to find it and could so I thought maybe qnx works differently to whatever system they where referring to in the docs.

What do you suggest? shall I reinstall samba?

also when you write:

what would IP be on a dhcp based rounter system? (aren’t IP’s dynamic) and is WIN_MACHINE_NAME the windows machines netbios name? The fs-cifs docs talk about using the following format: //NETBIOS_NAME:IP(or SMB_SERVER):?sharefolder. Why is there a difference?

Thanks again for your help.


Hi Banks

Its better that u reinstall Samba again bcoz it seems that samba installation on ur machine is not proper.

Well regarding DHCP based router system i’don’t have much idea. But what u can try is once ur WIn pc is started on lan try following command from cmd prompt of windows
ipconfig (to get the current IP address.)
then to get machine name try
nbtstat -A IP_ADDRESS

Rgdg ur doubt about ip_address:Machine name or machine anme:ip_address both way it is fine for fs-cifs .

prashant :slight_smile:

Thanks Again prashant.

I will post back if I hanve any more trouble.