QNX 6.3 in VmWare Workstation 6


in the last years we used QNX4 + QNX6 inside VmWare Workstation 5.5.

To get USB working with QNX6 we needed to use the following statement in the vmx-file: uhci.newCore = “FALSE”

We are planing to update to VmWare Workstation 6.

Did anyone use QNX6 inside VmWare Workstation 6 ?
Does USB works ? Is there also a special statement needed for USB ?

(Does QNX4 also works in VmWare Workstation 6 ?)

Best regards,


Yes, I tried using QNX6 on VmWare 6. It works fine. I didnt try using USB though. I tried it on Windows Vista Home Premium.


I had no trouble getting QNX6 up in VmWare, but have not yet got QNX4 installing. Something is going wrong with licensing that I haven’t gotten around to troubleshooting. This was on a Dell D820 laptop.

QNX4 works fine. QNX6 also but you need an updated usb driver.

Thanks for the feedback !

Can I download the new driver, or must I contact QSS ? Do you have a PR number ?

I think it was posted in the BSP forum on foundry27.