restore CF qnx system from windows?

I have created my qnx system in CF card,but sometimes the cf can’t work,it can boot but some dir lost,now I want to restore it under windows,
Is it impossible?because usually the cf card reader only can work under windows,but the windows can recognize qnx file system,how to do?

Windows doesn’t understand qnx filesystem.

Have somebody done the same work before?Is it possibel using ghost or other tools?

I need write the data of cf(qnx) to one new cf card,the problem is:
1)in qnx(or under vmware)can’t recognize cf card reader(usb)
2)in windows it can recognize cf card reader,but can’t understand qnx filesystem

The USB CF card reader should work under QNX - at least, I have one that does.
As a test you could try to mount an USB memory stick.

My configuration: QNX 6.3.2 installation in a VMware (version 5.5.2) container with an USB CF card reader.
I had to add the option uhci.newCore = “FALSE” at the *.vmx configuration file of VMware.


“I had to add the option uhci.newCore = “FALSE” at the *.vmx configuration file of VMware”
where can I change?

I do just as you said,add the “uhci.newCore = “FALSE”” at the .vmx configuration file of VMware,but when I log in qnx,it can’t find the cf card in /dev as hdt79,why?My qnx is 6.3.2 and the VMvare(5.5.3)


I don’t know if the “uhci.newCore = “FALSE”” option is necessary or helpfull for VMware 5.5.3. I can only speak for 5.5.2. There is a VMware project at the QNX website - maybe somebody can help you there with this:

But check this first:

  • did you add a USB controller to your VMware container?
  • can you select your device from the VMware menu “VM->Removable Devices->USB Devices”?
  • is the USB server started on QNX? (check with the usb utility, look for /dev/io-usb/…)


Yes,you are right ,thank you

We are you using CF card readers with the following versions:

VMware 5.x works without changes
VMware > 5.5.3 uhci.newCore = "FALSE
VMware 6 (latest) updated io-usb + + from


my VMware is version 5.5.2 build-29772. I just did a test and it doesn’t work WITHOUT the uhci.newCore = “FALSE” option.