Getting SAMBA to start

I am new to qnx unix/admin … I installed the samba package but its
not clear how to start it using smbd and swat … any one have any
pointers on how to do this?

Start smbd in the file /etc/rc.d/rc.local.

As for swat you need to edit the /etc/services and /etc/inetd.conf. This is not QNX specific and is well documented in the SAMBA documentation.

Greetings –

Thanks for your reply.

I have followed all the noted steps in the available doc, but could not
get swat to start … Is there some way to debug it startup?

kill inetd and start it with -d. It will show what it’s trying to do when you try to connect to it.

Greetings –

Thanks … I got swat to start, but when I tried to map a share I created,
i get this message from win/xp

The account is not authorized to log in from this station.

Am I missing a setting on the samba server?

I suggest you read the documentation. There are too many variables involved to give you an answer. One would have write the documentation …

Thanks for your help

Follow the procedures to install and run the smbd as per this site mentioned below … rtid=21733

and use the attached smb.conf file and samba verion Samba-2.2.7.tar.tar (download it from
it worked for me and it should work for you too…