Installing fonts?

I have QNX 6.2 and would like to install a few .TTF fonts I had in Windows into my QNX installation. I’ve read through the helpviewer and see that it is possible to use .TTF’s with QNX, but I cannot seem to get them to work.

First I tried double-clicking them in pfm, as it has an ‘association’ set up for .TTF files that copies them to “/usr/photon/font”. Yet there is no such directory, and creating one does no good either. I then tried copying them to /usr/photon/font_repository to see if that might do it. That time I couldn’t even get it to copy them there. The final thing I tried before I gave up and asked for help was to copy the fonts to ~/.ph/font but that didn’t seem to do it.

FYI I checked in the Font Administration program to see if they were in the drop-down list, but they weren’t. I don’t understand how I can go about installing fonts.

I think after you copy the TTF font into /usr/photon/font_repository, you
need to restart photon as root, the font manager will then realize
there is new font, and try to rebuild the font database. There should
be a command for doing this, but I just don’t remember :slight_smile:

All right. I quit out of photon completely, logged in as root, and copied the files to /usr/photon/font_repository without any errors. :slight_smile: Then I restarted photon, and it found them. Thanks for the help. :smiley:

Does anybody know the command for installing a font xtang was talking about above?
I have to experiment on settings of a font. so it’s quite annoying to reboot the machine each time I’ve changed a setting.
Thx a lot!

Actually, fontsleuth runs as resmgr overlay on /usr/photon/font_repository and tracks all new updates.

So there is nothing to do.

there is a command called font_install which I belive forces the fontmanager to rescan the font directory.