Tcpip ate my license


After successfully initiating Net, netmap, Net.bcm57xx (I have not been able to find a way to start them automatically during the startup :frowning: ) I tried start “Tcpip mymachine” (this mymachine name is a random name I picked --even though I looked in /etc/hosts could not decide which one to pick, and I still not sure how to initiate Tcpip correctly --with an argument or without an argument?) first it worked, then I initiated “ifconfig” by typing “ifconfig en1” I did not get my “ping” working and attempted to re-initialize everything. Once I got to the Tcpip point for some reason I got “no license” error. I don’t expect that we have one-time trial license, do you have any idea what could be the reason on my case?

I haven’t been able to succeed with Tcpip configurations yet due to this problem. I am sure the answers lie some point in /etc/hosts and /etc/netstart file but not fully understand how should I modify these files.

On this posting: Connecting QNX to the Internet mario said:

Based on this quote I would like to start dhcp client as a first option since we have dhcp server, but as I told havent gotten this point yet. If not I can go for manual configuration option as well.

Thank you very much again.

Looking forward to see your comments.

Is nameloc running before ifconfig?

Try sleep 1 at sysinit between nameloc and network start up

Juan Manuel


For some reason neither my hard QNX v4.25 nor virtual one has “sysinit” file under /etc/config directories. Should I create this file manually?

Tomorrow, I will check whether nameloc running or not.

/etc/config/sysinit.$NODE (ex /etc/config/sysinit.2)

You should also have an emergency /etc/config/altsysinit

Juan Manuel

Thanks for your helps once again. I finally managed to ping google :slight_smile:

Here is a bit information regarding our QNX4 usage. I am a graduate student in an atmospheric science department in a US institution. Our research team focus on weather modification subject more specifically to enhance precipitation in various countries. QNX 4 based data acquisition system (to acquire data from various atmospheric measurement instruments) has been used for over many years I guess mostly because its reliability and real-time nature. Due to our main acquisition program runs only on QNX4 we were not able to upgrade to QNX 6.4. Along these postings my aim was to establish remotely our QNX 4 machines which will be located on far ground platforms so that we can access them without a need for another person. (Also we will be able to modify our data acq system that sits in our lab without going to the lab :stuck_out_tongue:) Anyways, enough story. Below descriptions show what I have done to make my QNX4’s TCP/IP comes alive. I did lots of trials and errors and tried to things as simple as possible in my config files.

Starting with sysinit (Although I have a sysinit.1 file under /etc/config my system uses sysinit as the main startup script. Renaming this files caused a fatal error, but fortunately I was able to boot up with the backup copy :slight_smile: and reverted the change to its original state.

I have a Broadcom 570x Gigabit Integrated Controller. Thanks to an update that I come accross on QNX4 updates page I made it work. One additional thing in these lines everything works without adding “sleep” commands.


For some reason none of the modifications I have made on host file was used neither by Tcpip nor ifconfig. I tried aliases as well in the end I commented out my physical IP and everything worked fine.


Then I set the nameservers properly in /etc/resolv.conf file

And the longest content is from /etc/netstart file

Here Tcpip works fine no matter what I tried as an argument either a name from hosts file or made up name just like on my current configuration. For an unknown reason ifconfig en1 has not liked my names from hosts file whenever I tried I got bad value errors during the system startup. So I tried to write the actuall IP address itself and it worked :slight_smile: After setting a default route address and starting the inetd process I even managed to phditto to QNX 6 :slight_smile: which was a bit beyong my expectations. My mere aim was to be able to access the QNX4 from 6.

Actually I have one additional question. Is there a way to dynamically configure all these IP settings?

yes, if you have a dhcp.server you can use dhcp.client.

Well, could you be a bit verbose?

I know that our network has dhcp server but I am not sure where should I look for dhcp.client. Is it in /usr/ucb/ directory? If so, is there a manual to explain the necessary configuration settings?

EDIT: I configured dhcp.client and happier with this configuration. All I had to do was comment ifconfig lines in my /etc/netstart file and add dhcp.client &, and if_up en1 lines :slight_smile:
Although I get if_up retries exhausted warning during boot up TCP/IP works fine.

hi gsever,

if you are looking for a specific file or utility, such as dhcp.client, you could always type :
find / -name FILENAME -print or

you can look up detailed information about utilities and their settings at QNX’s web page; armchair readable manuals ready to take your scribbled notes are very difficult to come by; if you are interested, I could browse my harddisks for a PDF document about the utilities, I faintly remember having it down loaded sometime in the last century - ooh, and then I would need you email adress of course.

good luck ! Helge

Thank you for the hint Helge,

I will send a private message shortly regarding to PDF files.



I have one additional question. On one of our QNX 4.25 for some unknown reason TCP/IP is not initiated during the system boot up. I checked that /etc/netstart is in /etc/config/sysinit file, but I got no such process errors from ifconfig and other utilities that are connected to inetd tool. Interestingly I can manually initiate the TCP/IP after my system is up.

What could be the possible cause for this error? Do I need to re-build the boot image or else?

I don’t think you need to re-build your boot image. I think it’s about your sysint configuration. I had similar problems many times… or solved by sleeps in sysinit file (maybe is not the best solution, but it worked for me)…

Juan Manuel

Thanks for the suggestion Juan,

I will fiddle with my sysinit file and put some sleeps in it as you have suggested.


Putting “sleep 3” just before /etc/netstart line in my sysinit solved this issue. I do not know why not sleep 2 but 3 :slight_smile:

What is before /etc/netstart? where do you run nameloc in sysint sequence?


I do not have any nameloc entry in my sysinit file. For now everything seems like working without any problem.

You MUST have nameloc.