OEM QNX4 Application, need to access data

Moderator: If this is posted in the wrong section, please move.

Thanks to all in advance for any help you may be able to provide.

I’m needing some help in retrieving data on what appears to be a QNX4 system. The hospital I work for has not had any maintainence contracts with the application vendor for several years now. As I seem to understand the origins of QNX, that QNX4 was licensed o several applications vendors to do with as they will for their applications. Therefore, they were not obligated to provide any root level access to their applilcation customers.

This particular application contains data that the hospital must keep and demonstrate abilities to retreive on demand for the next 10+ years according to FDA regulations.

The system that it sitting on has a failed mirrored SCSI drive and an Adaptec controller which is also to seems to be suspect. I have tried some attempt towards recovery, if I can find replacement hardware, by copying the partition(s) with G4U (Ghost for Unix) utility.

The existing system and /or permissions will not allow (or doesn’t have) a way to turn on TCP/IP much less NFS.

  1. Was/will G4U create a usable restoration?
  2. Is there an XP/Vista utility to read the data within the QNX4 partitions?
    (I have already tried EXT2IFS on the G4U copy, either not using correctly or it doesn’t understand QNX4)
  3. Is there a way to put an IDE driver on the existing system or better yet the G4U copy to allow it to boot on a basic IDE-disk desktop? (the G4U copy starts to boot QNX4 (basic banner shows, then just hangs at hit ESCAPE to boot alternate OS). This would allow be to at least get the application moved the VMWare.

Ideally if someone had ideas on just how to get the application data off to be move into an SQL database would be most helpful.


If it’s done on the same machine ( same BIOS ) and the disk are of the same size your chances are good


If it’s a mirror raid thing could get very complicated… If it’s just a second HD, You could get QNX6 install it in a PC or vmware, then install the SCSI disk and try to access it from within QNX6.

Not an easy task, given that the way the data is stored on the device is unknown.

I might be able to help you, but first a basics.

  1. What adaptec card? Was it a RAID card? Doubtful. There never has been any support from QNX for an adaptec RAID card. As far as I know, the only RAID card that was supported was one I helped port. There may be others. Connecting a RAID controller to a SCSI card was more common. If this is the case, what RAID controller?

  2. Do you know what level RAID was being used? If it is 0 (Not really RAID at all), you are SOL. RAID 0 is not redundant, but was for performance only. RAID 1? This is the most likely and the most promising. If so, and you only lost one drive, the data should all be there and accessible. In fact it should be readable with another setup if you can find where the data physically starts. There may be a header put on the data for the RAID card/controller, but otherwise it should be sequential and therefore readable. QNX file system pointers are always relative so it shouldn’t be hard to move the data to another drive/system and access it.

It is unlikely that after putting it on an EIDE drive that you will be able to boot from it, but there’s no reason you couldn’t put QNX 4 on an EIDE, and copy your data to another EIDE partition.

Putting the data into SQL has little to do with the previous challenges, it depends on what the data looks like.

I’ve done a lot of low level data recovery with QNX in the past, and I know MySQL well. I’ll have time to work with you on a contract basis in a couple of weeks if you so desire. (yes a shameless plug). You can contact me at maschoen@pobox.com.

Sorry for not posting this followup sooner.

Thanks for the replies.

I installed the QNX4 G4U copy disk on IDE-0 slave and a 10GB FAT32 formatted disk on IDE-0 master. Booted the QNX6 CD. Both partions showed up uner /fs. I was able to easily copy files between the two partions. Installed/mounted the 10GB FAT32 disk on an XP machine, transferred the applications data files to our file server.

I did run into a bit of difficultly, most likely due to inexperience with UNIX much less QNX. The 10GB disk, I used fdisk to create a type 12 (FAT32)partition. It showed all available (10GB) partitioned. Then I used mkdosfs, but it would only format 1.5GB. And even with this, after rebooting QNX6, QNX6 did not see the partition under /fs.

I cleared the partition with CPM (Cute Partition Manager), then used CPM to create a FAT32 partition. Attached the disk to an XP machine, allowing XP to partition and format the disk. Attached it back to the QNX6 machine, booted QNX6, then it showed up in /fs.