Free Partition: 2nd HDD (USB). Both CD and DVD don't boot.


I want to install QNX.
I can’t find tools in Linux to format to qnx4fs or qnx6fs. So I left the free partition unformatted. It is located on the second HDD via USB.
When booting from the CD or the full DVD the QNX-installer in both cases finds the first as well as the second HDD and recognizes this one as USB-drive.
There’s no surprise in the second message I receive (“no qnx 6.1 or greater filesystems available”) because there is no such fs yet (if not shipped with the installer DVD).

The first error message seems more significant to me:

Trying SATA mvSATA. Scanning for devices. xpt_configure: No mvSata interfaces found.

What’s wrong? The md5sum of the DVD is correct.
Thanks a lot.

Edit: I tried it once again with an empty partition on HDD1. Same error, no boot. It’s been a logical partition. Does it have to be a primary partition? I’d like to know this before deleting another OS on a primary partition and not find it out by doing so. Thanks.


This just means there are no recognized Sata devices found.

I am sure you’ll say you have a Sata CD-Rom or a Sata HD.

Prior to QNX 6.4 (you don’t mention which version you are trying to install) there was limited Sata support for only a very few chipsets hence you have to have the BIOS turn Sata Devices into IDE emulation mode.

As far as installing QNX goes, it can install on either the primary or secondary partition.

So if you are having trouble getting QNX to install on your USB drive or on the Sata drive, check your BIOS settings for IDE emulation mode and make sure it’s set to emulate IDE.