Mozilla 1.1b

For those of you who want to beta test the mozilla 1.1beta. I made two binaries available for download: the first one is mozilla-xlib and second one is mozilla-gtk.

Both versions require eithier XFree86 or XPhoton to run. I only tested it under XFree86 for QNX 6.2 but I would expect it run fine under QNX 6.1 and/or xphoton. I’d love to hear from people with different configurations.

You should normally choose the mozilla-xlib which only uses the base X Window libraries, should be smaller and faster. But the mozilla-gtk version is the most widely tested version from other Unixes, which means it should be less buggy. It also gives you the ability to use different gtk themes. It requires gtk/glib libraries of course.

Pick one to download, and you can install it by “cd /; tar zxvf the_downloaded_file”. Everything will be installed under /opt/openqnx directory. You can then run it with “mozilla-gtk” or “mozilla-xlib” (if you have added /opt/openqnx/bin to your PATH); or just give the full path of the command.

BTW, Kinners and cdm are busy working on the native photon version. Please be patient since there are still some bugs and performance issues need to be nailed down. An update will be posted when that version is ready. In the meantime, photon users are encouraged to try either the mozilla-xlib or mozilla-gtk under the XPhoton. The xphoton emulator layer doesn’t seem to have any bad effect to mozilla last I heard, probably because most of the mozilla GUIs are dealt internally in mozilla rather than relying on the GUI toolkit. That explains why you don’t see any look/feel different between mozilla-gtk, mozilla-xlib and mozilla-photon.

That’d be nice, but as far as I know, you can’t use gtk themes in QNX, at least under 6.2’s XPhoton. They just won’t work.

There was one major complaint I had about the Photon version of Mozilla 1.0 RC2. Cut and Paste between it and other Photon apps was not functional. This was not the case on the version that came with 6.2 though.

1.0RC2? The latest version of mozilla-photon that I know of is 1.0 release. You should try that.

this url seems to imply that you can do some limited gtk themes in xphoton.

I didn’t know about the 1.0 release of mozilla for photon as I only got the one from the OpenQNX page a while back.

I didn’t know about that theming trick… when I tried nothing happened with the themes I used. Perhaps they were all using the default colors or something?

If you are using photon, you should probably get the official mozilla photon 1.0 release from QSSL

Have you tried it in the real XFree86 rather than the XPhoton? the mozilla-xlib and mozilla-gtk are really targetted for real XFree86 users. Photon users may be able to get it work with XPhoton while waiting for the native photon version, but you may or may not have all the bells and whistles of the true XFree (like the gtk themes).

I haven’t gotten XFree86 working in QNX yet… :frowning: I never really learned anything about it, as I’ve never used Linux or any other *nix type OS except occasionally, and it seems to have a problem working on my Voodoo5. Probably a configuration option that I didn’t set up right or something. I still like Photon. :slight_smile:

Also I never even knew there was an official 1.0 binary. :smiley: Can’t believe I’m so behind on everything. :laughing: (darn we need a better laughing emoticon… this one looks like… just terrible. lol)

After my clean initial install on a blank 2gig partition, I can’t run mozilla ?

It is installed in /usr/photon/bin.

I tried to run it from gui and command line. It just comes back with the prompt. The terminal shows no errors.

Any suggestions ? :astonished:

Based on your Post Subject mozilla on 6.2 iso, I assume you are talking about the mozilla version that is bundled in 6.2. I have never tried that, maybe other people can give you more advice. I would suggest you try the latest mozilla version 1.0 for photon. You can find the download info in my last post.

delete your old $HOME/.mozilla and try again.

I don’t have a $HOME/.mozilla.

sounds like your mozilla doesn’t work at all. I’ve never seen cases where there is no $HOME/.mozilla.

Since there are major issues with mozilla-photon, I would suggest you download and try my mozilla-xlib port while waiting for the next release of mozilla-photon. The reports I got was mozilla-xlib works very well under XPhoton. As for mozilla-photon, last I heard Kinners made some major improvements but we don’t know when it will be available for the general public.

I was looking through the photon code in Mozilla and it looks as if it hasnt been touched in quite some time (at least 2 months - which is forever in mozilla). Look for yourself.

As for Kinners - hes not usually the quickest, he requires a good proding now and then.

OK, so After I do a clean install of 6.2 iso how can I install the mozilla-xlib. I’ve already downloaded it and know how to untar it, but what other software is needed for it to run ?

hm, wondering why hasn’t checked in anything for so long. Maybe he is busy with OTHER business since his head showed up on the 6.2PE box :smiley:

You need to download/install the XPhoton emulator:

untar it. then modify /usr/bin/ph to change all /usr/X11R6 to /opt/X11R6 and Xphoton to XPhoton. Restart photon and you should be able to run /opt/openqnx/bin/mozilla-xlib

Since he is working free for the QNX community, we can’t blame him :slight_smile:

I have an idea, maybe we should give some incentives to Kinners so that he can spend some more time and release the mozilla photon sooner. If you need the new mozilla-photon and want to contribute, please PM me with the dollar amount and I will collect and pass to Kinners.

We should probably create a new forum like “Request a software”, where people can ask for a new software to be ported or to be written, give the dollar amount he/she wants to pay. Developers can then pick up whatever he/she is interested or where his/her expertise is.

:exclamation: :exclamation: :exclamation: :exclamation: :exclamation: :exclamation: :exclamation:

emulator? ICKKKKKK! It’s not an emulator! An interperter… perhaps… but not an emulator…

As for request software - not a bad idea… I might have made some money this morning when phearbear asked me to port FriBidi ;o

I always thought of it as a ‘wrapper’ of sorts…

I am not sure which is a good term: wrapper, intepreter, emulator. The reason I called it emulator is probably because of exceed. Hamingbird Exceed is called an X emulator, which allows you to run X protocol applications in Win32 native GUI. This is more or less similiar to XPhoton, which allows you to run X in Photon native GUI.