Sleep consumes less time than should


I built the system and I invoked sleep 100 from shell.
Unfortunatelly sleep 100 consumes about 4s instead of 100s.
Do you have idea what is the reason?

On my board system timer uses clock 32,768 kHz

I use following macros:
#define AT91RM9200_CLOCK_FREQ 32768UL
#define AT91RM9200_CLOCK_RATE 3051757813UL
#define AT91RM9200_CLOCK_SCALE -14

According to documentation CLOCK_FREQ should be equal 1/(timer_rate*10^timer_scale) so settings should be correct

Do you have any idea what is the reason?


Where did you use these macros?