Qnxnc621 and Photon dialer question..

I asked the question on comp.os.qnx anf was directed here.

I have installed qnxnc621 under vmware-4.0 and would like to use disl-up
to school computers. I have an external USR-Sportster modem on COM1 (/dev/ser1). I tried the photon dialer first with modeom-inittializer-string
ATE1Q0V1 (modem always responds to that under other systems). When
connection is tried, the terminal window shows:
Connection failed

no matter what the intiializer string!!

.ph/dialups/isp.dlp file contents:
#photon dialer config file version 1.3

device /dev/ser1
protocol PPP
device_type serial
number xxxxxxx
speaker off
modem_init_string ATE1Q0V1
line_speed 57600
login_type manual

I also tried to test modem using qtalk -b 57600 -m /dev/ser1,
I am able to connect to the other -end manually, PPP connection chars
(garbage characters) are visible too. So I tried to quit qtalk without
hanging up the modem (x in command mode) – it hangs up the line
(exactly as q in command mode). I can’t start pppd and force it use
/dev/ser1 connection (already made)?

Any pointers will be appreciated.

Can’t you just let the Windows box to the dialing and then config VMWare to use the NAT network? Just a thought, never tried it ;) Let us know if that works.

Or, if you really want to do it in qnx, you may try the the ppp scripts in ftp://ftp.qnx.org.ru/pub/projects/fliu/ppp.tar.gz Run “ppp-up” script in there to bring up the ppp link, and the “ppp-down” to bring it down. You may need to modify “ppp-up” to fit your needs, and the secrets file for the password …

Good luck!

I have been using it via Win2K dial-up (witn NAT in vmware). I did
the ppp-up script (out of ppp.tar.gz) but had partial success:

  1. disabled en0 (ifconfig en0 down)

  2. checked with ifconfig -d

  3. dialed out with ppp-up (the string ATE1Q0V1 worked…)

  4. ifconfig -a does show
    ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
    nwid “”
    tunnel inet →
    media auodetect
    inet → netmask 0xffffff00

  5. there is no response to ping/telnet/ftp attempts…

I am stumped here!


hey, you are getting there :slight_smile:
can you ping the IP address of the PPP link? and

My wild guess is there is a problem in either your routing (netstat -rn) or DNS (cat /etc/resolv.conf, getconf CS_RESOLVE )

I had to take out the “noipdefault” option from pppd options
for ping to work right!

Thanks a buch for the help.