QNX 6.1 boot problems

Hi everyone,

Below are 2 problems which I ran into on 2 PC’s.

  1. On one machine, every time the PC is booting, there are following lines
    appearing every 2 seconds or so.

Detected EIDE Scanning for devices
simq_timer: building abort ccb
ata_start_ccb : func 10

  1. On another machine, the boot process cannot go through unless I select
    the following boot options
    F11 : Enumertor disables
    → F2: Disable the plug & play ISA enumerator
    (this problem is quite confusing, as far as I know, the ISA device is not
    PnP. does this problem mean the ISA is not supported in this istallation?)

Can anybody tell me how to fix? Thank you!

  1. Post of the spec of the machine. I seem to remember old QNX had issues with AMD. Also, since those errors came from the EIDE driver, you could try to disable DMA (hit ESC during boot) to see if that helps. Other possibilities are IDE CROM:
    a) make sure there is no CD in the drive when boot.
    b) make sure it is connected to master on secondary IDE cable.
    c) do you have two CDROM or CD burners?

  2. It seems enum-pnpisa is causing trouble to your hardware. You can try to rename it “mv /sbin/enum-pnpisa /sbin/enum-pnpisa.sav” so that it won’t get run during reboot. This should “fix” your problem.

Anyway, you are using an old version. Try the latest QNX 6.2.1. It may have fixed all your problems :slight_smile:

  1. It doesn’t help when I disable DMA. The 3 possiblities are all exculded. I don’t know other cause.
  2. Thank you!
  1. I thought it’s related to the master/slave issue. But you may have hit other problems. I am pretty sure QNX 6.2.1 will have fixed it, but you must have your reason to stay with 6.1 :wink: