How to run Epson Stylus C44 USB printer in QNX 6?

Does anyone know how to start the Epson Stylus C44?

I know I need to run devu-ohci and devu-prn, and I saw
the /dev/usb and /dev/usbpar0 popped-up. But I could not
verify are they ‘actually’ setting up the driver properly.

I tried to run lpd with the following /etc/printcap

queue1|Epson Stylus C44:\

I tried to print some file like
a2ps -Pqueue1 /etc/printcap,
but nothing get printted, and it seems that the print
job was done immediately. ( a little bit like printing to /dev/null )

Could someone give me a hand on this?

you don’t normally need lpd in QNX, unless you are trying to setup a network printer. QNX uses its own print spooler. Check the discussion in this thread:

to verify, you can do
cat >/dev/usbpar0
hello ,this is a text
(as mentioned in above thread).

You can then start the spooler with
spooler -d/dev/usbpar0 -c epson.cfg -nMyUSBPRN

Now you should be able to print from your GUI applications.

I tried to do cat > /dev/usbpar0 without starting lpd, but there is no respond from the printer. And even if I start the spooler, it seems the print data just fall straight through the spooler and the printer is still doing nothing.

How do i check whether is there a communication lost on the path from /dev/usbpar0 → /dev/usb → printer?

If using ‘cat’ to send text directly to the printer doesn’t work, there is no need to try spooler or lpd.

Have you disabled Legacy USB in the BIOS? What does “usb -vv” and “pci -vv” say? If you have multiple USB controllers, you will need to start a driver for each of them. To do this you need to use the ‘-p’ option and the ‘-n’ option.

Not all printers accept ascii text - although most do. It is possible that this printer can’t print text and that is an invalid test. I suppose you could check the printer manual, although I doubt it would say. You could also try copying text in a windows command window. The syntax is something like ‘copy con: lpt:’ although it has been a long time since I tried that (and since you aren’t on the printer port (lpt) I don’t know the correct device name).

Anyway, I have seen a few printers that can’t print ascii text, so don’t get off on a tangent unless you know your printer can.

Thanks for the advice. I didn’t know that there were two usb controllers on my machine. :smiley:

But after starting /dev/usb0 and /dev/usb1 seperately and properly stacking /dev/usbpar0 on top of /dev/usb0, I still cannot print anything from the printer by sending to /dev/usbpar0. The data going into /dev/usbpar0 just vanishes…

Also tried to start the qnx spooler and print from there, same as before, data just fall through the spooler and print in no time so nothing get queued in the spooler.

Still doesn’t solve the problem… :frowning:

Since you have two USB controllers, maybe your printer is connected to the second one? have you tried stack your devu-prn to /dev/usb1?

tried both, but still, no positive result.

I must have done something wrong somewhere… :open_mouth:

Don’t know what to say man :frowning:
I would see if cdm or rick has more suggestions.
Have you checked your BIOS to see if there’s anything related to USB?

I’d ask if there is a CUPS implementation for QNX. That’d be a good
general solution… if it were available. - BJ

FYI the Erlang appears to be up. Charles is putting the finishing touches in now. bj

If I read the thread correctly, he couldn’t even send the characters to the physical port. CUPS probably won’t help him in this case :frowning:

Congrats! Look forward to your news announcement :slight_smile:

Jacob is one of our engineers, on an extended leave to do his PhD. If it annoys him enough he’ll probably port it himself so that it will work :slight_smile:


Or I will