Trouble with phditto

I’m trying to get phditto to work on an embedded system. I’m hoping someone has run into this problem and has an idea. The target has two QNX partitions. One has the development system. I can phditto to it without any problems. The other partition has just my target files.

When I try to ditto to the target I get the login screen. If I try to login, phditto goes away.

Things I’ve already tried.

  1. Make sure inetd.conf has phrelay uncommented
  2. Make sure phrelay is in /usr/photon/bin
  3. Make sure phlogin is in /usr/photon/bin
  4. Make sure system is up and running with Photon
  5. Tried with root having a password and not having one
  6. Tried copying all of /lib /usr/lib /usr/photon to target
  7. Check sloginfo for any errors

I’m pretty baffled. Must be something isn’t setup right.

Any ideas?


I’m the one who solved this. 3 hours of careful tracking down differences paid off. In the end the solution was kind of obvious.

I was missing ph and phin from /usr/bin. Putting them in solved the problem.

If anyone is listening at QNX, I think a descriptive error message somewhere, maybe on the screen or maybe in slogger would be helpful for the next poor soul.

QNX Support would have been able to help you out, they’ve done this plenty of times. :slight_smile: