Mobile Radeon 9000 support?

From … video.html , it claims that Radeon 9000 is supported with 6.21B (which I have). At least for linux, there is no difference between the driver for mobile and non-mobile version so I assume it should work the same in QNX.

However, when I change the driver to radeon,
io-grahpics -g1024x768x24 -d0x1002,0x4c66
photon refuses to come back up after I click reply.

For 16 bit and 8 bit color:
io-grahpics -g1024x768x16 -d0x1002,0x4c66
io-grahpics -g1024x768x8 -d0x1002,0x4c66
photon does come back up by the screen flashes with streaks and is unusable.

Is the vesabios at 1024x768x24 my only option? I notice that the driver is quite slow even when doing a ls for large directories in terminal.

If QNX is not autodetecting your radeon, then chances are it is not yet supported. The good news is QNX has really good support of ATI video cards, so if the support is not there yet, it should be in the next version.

There is a chance that the existing driver would work even tho it didn’t know your device id, but from what you have tried, it doesn’t look like it.

So for now, the vesa driver may be your best option. Again the good news is that one of the users here (evenh) created a slightly accelerated driver for vesa. Search here or at QNXZone ( for evenh and vesa drivers and you should be able to find a link about the driver.

This driver is certainly fast enough for most things you want to do with QNX.


Thank you rick. I checked ATI’s own support pages again and it looks like the Mobile Radeon 9000 (M9) did=4c66 is not supported by QNX yet. I am a bit surprised that
has claim that it works. I’ll try to find out from that person what he have to do.

Officially the support is not there. I will also try the accelerated vesa drivers then.

mail me at and i’ll help you get it all working if you have that laptop :slight_smile:
(Yes, i am the owner of that page)

Marry christmas btw!

Just to post an update here.
I got some pointers from phearbear who is very helpful. It would seem that the radeon driver sort of supports some of the mobile radeons but not at the standard refresh rate of 60. For phearbear, setting -R53 works for him. Unfortunately, what worked for him with the Dell 8500 doesn’t work for me. With many restarts, I tried refresh rates from 50 all the way to 65 with no avail. My machine could be a different chipset than his (There are 4 known mobile radeon chipsets according to the Linux ID list).

Now, I have just tried out Evan Hallis’s improved (impressive!) vesabios driver as Rick suggested and it works great. a “ls” command is fast enough that I don’t notice a lag.
For others who are in this sort of a jam Evan Hillas’ page with the driver is here:

evanh moved his enhanced vesa driver to