Installing 6.2.1Help!!Cant get past Display settings screen

Downloaded it yesterday, burned the image, made free partition(2gb) on primary disk, booted into installation.
Everything worked well until the display settings screen. I couldn’t select anything and both my mouse (tried ps2 and usb) and my keyboard weren’t responding.
Booted again and tried liveCD option, same story.

My system

P4 1.60
512 mb ddr
asus p4p800 deluxe
3 eide HD
CDRW Teac 52x
Geforce 4 ti4200 8x
cmi8738 PCI sound card
US robotics v92 external modem connected to COM1

Any suggestions? Thanks.

Which version of QNX? 6.2.1?
It could be your video card issue. … ight-.html
If you are using an old version (6.1), it could be the bug in mouse driver (devi-hirun) …

I have tried as suggested with vMware, but when QNX is configuring(reading vesa drivers-original) vMWare makes an exception error.

When booting directly Qnx(without vmware) QNX insists on booting into Photon even if F3 has been chosen during setup.

So I rebooted again and this time it let me without Photon but asks for login and pass??? I havent had a chance to even set my login options.

I have downloaded qnx621.iso 247 megs file from this site( I actually searched for mirrors because does not support resume downloads).


I found ot in another article that login i root and qnx will not ask for pass. good.
I logged in and typed cd /lib/dll . and then what? How do I rename files under qnx? I have no knowledge about qnx (unixes console commands).

sorry I didn’t know you were trying VMWare.
Those two articles should help you out with that:

Hi NOC, I wasn’t trying vmWare at first but Your first link led to those post of new vesa driver and those led to vmWare. Anyway I found somconsole commands from linux that worked on QNX, and did manage to rename file after all.

Now system started regulary under vmWare but I cant see CD Rom (where new vesa driver is located). I know a little bitabout linux and there was a command to mount CD rom into system. Iwas under impression that Qnx does not need this, but if it does care for an explanation.

On the other han installing QNX on Hard drive directly led me as far as logon window behind initializing input devices smaller window and this is where it hanged with nothing seemingly happening. I have USB mouse and Keyboard. Idea?

Though USB keyboard/mouse is supported, the installer won’t be able to do it automatically, you will have to do some manual work/hacks to get it work.

I think you made the right choice to try VMWare with QNX first :slight_smile: VMWare will hide the USB keyboard/mouse and present them as normal PS2 devices to QNX.

As for the CD, it should be mounted automatically under /fs/cd0
If you try to install QNX packages from the CD, just click the installer on the GUI shelf and it should pick up the CD content from /fs/cd0

Noc it is me again, sorry to bother, but QNX is quite a strange beast from someone coming from Windows.

How can I see files on CD through file manager? Dose CD has to be in some format different than joliet. I have in Nero Burning ROM option to burn UDF(universal disc format) type of disc. This worked under MAC OSX, and I was able to see the files on CD-ROM. Here however, file manager sees only the root (or it is me doing something wrong) and the installer does not see any package or driver stored on CD that I burned and behaves normal when I insert QNX 6.21 disc.

I know this may seem trivial to a majority here but sadly it is not for Windows user. Thanks again.

As for USB I am quite ready to dig in into problem if You leave me pointers :slight_smile:

I may be wrong, but I don’t think QNX supports UDF.