QNX PC to Windows PC connection

I am new to QNX RTOS,
I would like to set up a network connection between a PC with QNX 6.2 and a PC with windows XP. I have installed QNX in the first PC and I could log in. Both PCs are connected to the LAN. I would like to know how to find and set the IP address for the QNX PC and communicate with the windows PC.
I tried the Network manager, however the Device Tab does not appear, to be able to set the dhcp to manual.
I would appreciate a step-by step procedure for setting up the connection. Do I need to download additional network drivers?
Your help is greatky appreciated.

Im having the same problem as you are getting the netcard to connect to the network via dhcp, So I cant help there. What I can recommend is that you run nicinfo from the terminal to make sure your network card is supported and properly configured.

Now, once you manage to get the card to connect to the network via dhcp, you will have another task to do before you can connect to the windows pc. You will have to get samba from the online repository so that the qnx machine can communicate across the network with the windows pc.

If you are missing the device tab it means that the system is unable to detect any network card. If it’s present and has problems then I am not so sure.

The following two threads should help you get the basics:
openqnx.com/PNphpBB2+viewtop … t-100.html
openqnx.com/PNphpBB2+viewtop … t-100.html

What you have to do is to find out what chip your system uses through “pci -v” You should be able to see the PCI device type as Ethernet. Note the Vendor ID (vid) and the Device ID (did)

Even if your card is not officialy supported the driver may still work b/c it may just be a newer chip revision that supports the same driver (but cannot be auto-detected). If you have problem identifying your chipset post the vid and the did and we can try to look it up for you.

When you load the driver in command line you should have something like:
io-net -d DRIVERNAME -vid=0x???,did=0x??? -p tcpip

If it works follow the 1st of the two links I posted so that you can load the drivers through rc.local automatically.

Provided all these work then you should be able to set the dhcp or static setting through the Devices tab.

Thank you for your suggestions.
I tried to get the chip id and vendor id using the command “pci -v”, but I got the following message:

pci -v

/bin/sh: pci -v: not found
I used also the nicinfo command, and I got the same result


/bin/sh: nicinfo: not found
When using these commands, I am working under the directory /home/ntuser
where ntuser is the account that I created when I first logged in under root.
Is this problem related to the first installation of QNX6.2?
I hope to hear from you.

both “pci” and “nicinfo” are under /usr/sbin. If you don’t have them, your installation must be screwed. Have you finish your second stage install with QNX Momentics for x86?

I tried the commands from the directory /usr/sbin but I still have the same problem:

cd /usr/sbin

pci -v

/bin/sh: pci not found

“Have you finish your second stage install with QNX Momentics for x86?”
Can you please expalin what is the second stage of installation

If my problems are with the original installation, can you please suggest how and from where to dowload the full QNX and install it again?

try /usr/sbin/pci -v

if still not working, put the CDROM back in the drive, and click the Installer on the shelf. Once installer starts, select and install the “QNX Momentics for x86”.

I run the pci -v command under root and it worked I got the following info:
Vendor ID: 8086h, Intel Corporation
Device ID: 100eh, Unknown Unknown

I am not sure what is the driver name and why does it give the “unknown” message. Next I used the following commands:
slay -f i0-net
io-net -d speedo verbose=10,vid=0x8086,did=0x100e -p tcpip

Apparently it worked, I opened the Network manager and I got the Device Tab.
I dont know how to select the IP address. In the server field I put the main university server IP address, and when I click apply the following message appears:
Netmanger Warning
Netmanger error: Could not configure DHCP on interface en0
Netmanager error: could not start dhcp.client: No such file or directory.

Any suggestions? Thanks

I think you have a problem with pathes. I assume you logged in as a regular user, then used su to become root. The way I usually do it is ‘su -’ which brings roots environment so you can find the commands you need. Once you have done that, you may have to run phlip by explicitly typing it’s path.

/usr/photon/bin/phlip &

Most of you problem (aside being unable to automaticaly detect the network) are comming from the fact that you don’t run as root (as Rick suggested). User root has its PATH set to locate system utility but not normal user. Plus normal users don’t have the current directory in their PATH.

I recommand you edit the config file ( don’t recall the name) that hold all device ID and add the info for your card. From there it should work.

Note that it’s possible the speedo driver is not the one matching your NIC.