VMWare + QNX + No HTML?

I have a strange problem.

I have VMWare player 5.0.2. In this I’ve installed a QNX virtual machine (QNX 6.3, SP3 - Full Momentics development suite). QNX installed just fine and I have network access etc and Photon is running in 1280x1024, 32 bit color mode and I can select various resolutions.

However, it seems HTML isn’t working. For example I click on the Helpviewer in Photon and it starts up. But the main page where you view the text is blank (just shows the last thing displayed on the Photon desktop). The left hand side (topics, find area) all work fine. But no matter what I do the main view area doesn’t change. I tried starting the basic Voyager browser and going to google.com. I see it retrieve the data bytes but nothing ever gets displayed in the browser window. However other Photon apps (the games, calculator, file manager etc) all work fine. Is there some driver I need to download that I haven’t got or some setting that’s different in VMWare than in a normal install (The video driver in use is one called vmware)?

I found the above while trying to run qnxinstall (the old package installer) to install some 3rd party software (jed, ssh, tcpdump, samba etc). I’ve gotten the 3rd party cd .iso mounted in VMware and I can see it in /fs/cd0 as it shows a repository directory full of packages. But when I try to run qnxinstall as ‘qnxinstall -r /fs/cd0/repository’ nothing happens. By that I mean qnxinstall starts but I never see anything shown in photon (I am guessing it’s HTML based too) so I can’t install anything. Is this the only way I can install packages in 6.3 or is there another way I can do it.



Can you try a different graphic driver and/or mode. From memory it might be an issue with the driver not handling certain operation properly


Yup that was it. My only other options for drivers are svga (16 bit color) and vga. I picked svga and 1280x1024 and it works and I now can see the installer and the helpviewer.

But 16 bit color sucks and it’s MUCH slower graphics wise than the default driver of vmware. Do you know if this driver still works/is the latest for QNX/VMWare


Alternatively, it is still possible to use Phindows to access the machine in VMWare. Then I could leave the VM minimized and simply use Phindows to access the machine from Windows.


Now of course qnxinstaller is crashing when trying to read my local CD repository :cry: (trying to get a 6.3.2 version instead of 6.3.0 SP3 but not holding out a lot of hope that one won’t crash).

I’m trying to figure out if I can hand install the ones I want. I found this old article on the packager

qnx.com/developers/articles/ … 883_1.html

so I know I can list the contents of the qpk/qpr files with the command tar -ztf filename.qpk. Unfortunately these tar archives prepended directories in front of where they should actually install. Which means a lot of manual copying of files that’s going to be error prone. And no dependencies worked out etc.

Sadly I don’t seem to have this program to test install the packages

pkg-installer -u mypackage.qpr

Anyone manually installed before?