QNXSDP 6.5.0 CD wont mount QNX hard drive

The “MyGig” navigation systems used in Chryslers vehicle have hard drives with the QNX file system. The QNXSDP boot cd will mount the hard drives on all these systems released before ~2011. FDISK still identifies the 4 partitions as QNX partitions on the new systems, but the partitions are not listed in /fs.

I am no expert in QNX files systems - obviously - I only use the QNX utilties to increase the size of the 4th partition used for storing user content. I delete the 4th partition, then create a larger partition, then copy the content back to the larger partition. On the newer systems, I can access the content on partition 4 to save and then copy back to the larger partition.

Anyone know why these drives won’t mount, or how to overcome this issue. Could it be the developer used file permissions to only allow an account imbedded in the firmware of these navigation systems to access the file system ?

Maybe this is a clue . . . . When Clonezilla enumerates the drive, the partition list is not like the pre-2011 drives which have 4 partitions in Clonezilla and 4 partitions are mounted in the QNX CD.
In the new drives FDISK shows 1 of the 4 partitons as "extended’. In the pre 2011 hard drives there were 4 primary partitions no matter how you viewed the drive.

Clonezilla’s Partition List on new drives (notice sdb2 is not listed)
sdb1 11.7GB
sdb3 98.7GB
sdb4 26.1GB
sdb5 1571GB
sdb6 502MB

Also Clonezilla (using DD) succesfully clones these drive and they work in Navigation system.

Thank You

I assume that you are using a QNX development system to look at this drive. Assuming you are running a shell as super user, then there is no file permission that would prevent you from accessing the drive.

I can think of two other possibilities. You didn’t mention which version of QNX you are using, but that might be crucial. The original QNX 6 file system is often referred to as the QNX 4 file system, since it has almost exactly the same format as the QNX 4 file system. Recently (I think in version 6.4.0) a newer file system was released which is often called the QNX 6 file system. It is more limited in use and has somewhat different properties. It’s actually slower. However it has the nice property that if you create a file, you either get the new file, or nothing at all. With the older version you could get a file where the data never was flushed from the cache.

So my first idea is that you are trying to access the new file system with an older QNX version which doesn’t know about it. While the partition types for the QNX 4 file system were typically 77, 78 and 79, the types for the newer file system are 177, 178 and 179. This is not absolute. I think if you dump the first sector of the file system there is a stamp that might be telling.

The other possibility is that MyGig decided to prevent the type of hacking you are trying to do.
They could have implemented their own file system, possibly one that is more efficient for their purposes, or they could be using an existing file system, but with an encryption layer placed on top.

Regarding the QNX System - I am booted into the 6.5.0 CD when I look at the drive. Does that tell you what file system I am in ?

Regarding Partition numbers - FDISK lists the 4 partitions 77,78,79,80. Does that mean the hard drive is using the “old” file system ?

I mentioned that Clonezilla enumerates 6 partition on this drive. FDISK under the QNX CD lists 4 paritions and the starting and ending sectors used by these 4 partitions account account for all sectors on the Disk. So why would Clonezilla find 6 partitions ? Probably not relevant but a puzzle to me. The pre-2011 MyGig disks that can be mounted show 4 partitions in Clonezilla.

Are their QNX drivers where I could attempt to mount this drive under Linux - I thought I saw some forum topics about that.

There goes my first idea. You have the latest. Something else is going on, eg. a custom or encrypted file system.

Most likely yes. Rather than thinking of it as the “old” file system, think of it as the tried and true file system.

Well we’re getting out of my comfort zone, but here’s my take on this. QNX fdisk is using the same partition scheme that goes back to the IBM AT. It allows for 4 partitions. Now there was an enhancement to this scheme where you would have a partition which itself could be sub-divided. I recall Bill Flowers once saying that supporting this was easy, but I’ve never found support with fdisk. Maybe someone else here knows more.

And then I’ve noticed that there are some new partitioning schemes around. My Windows 7 system seems to do something different so that whenever I change a stick from Windows to QNX I have to wipe out the first sector. I also noticed that Apple has their own different version.

I don’t think the extra partitions are your stumbling block. If QNX recognizes them and can mount them, they are probably ok. The question is why can’t you read them.

I believe that there is code for Linux that will read a QNX4 file system. I doubt that there is similar code for a QNX 6 file system as it is much newer.

Since only 4 partitions are allowed and there are 6 on your drive it sounds like there are 2 extended partitions. As Maschoen says, the concept has been around forever (I used to use extended partitions back in the 90’s on my Windows machines).

I didn’t realize QNX didn’t support extended partitions. I would suspect that Chrysler wrote custom software to handle them.

Have you tried cloning just one of the partitions by itself to another hd/thumbdrive and see if that mounts in QNX? That should give you an idea of whether it’s an encrypted system or just something related to the extended partitions.


( I was on an assignment for a couple of weeks . . . now back )

Yes, I cloned one of the partition, then restored it to a different drive and the QNX boot CD still could not mount the partition.

I noticed today for the first time, when booting into the QNX CD, when its waiting for me to Press F2 there is a message . . .

"Unable to mount a qnx4 filesystem as /fs/hd10-qnx4 on /dev/hd10t79 (Corrupted file system detected)
and /hd10t78 (Corrupted file system detected)
and /hd10t77 (Corrupted file system detected) "

This message occurs on every working hard drive from this generation of MyGig systems. I have a drive from a North American, European and Australian version.

Does this message give a clue on how to mount this version ?

I’d say that indicates those 2 partitions are using a custom filesystem or it’s encrypted. In either case you are out of luck changing anything in those partitions.


The numbering of the partitions hd10-t7? indicates it should be a QNX4 filesytem, however it might be an a QNX6 filesystem. Hence you could try to mount them manually a force a QNX6 filessytem

mount -tqnx6 /dev/hd10t78 /blabla

If that doesn’t work then you could look at the first few block of the partition with spatch /dev/hd0t78 and try to analyse the content to see if it matches a known filesystem …