How to use qnet via null rs-232 cable?

I type command on PC 1:
io-net -dfd fd=/dev/ser1 -pqnet host=pc1

on PC 2:
io-net -dfd fd=/dev/ser1 -pqnet host=pc2

but on /net only apear local pc.

What’s wrong?

I writed 2 programmes, one send data to serial of PC1, another one receive data from serial of PC2, they work ok.

hlp me, thx. :unamused:

I’ll crazy since the vexation .
help me, pleeeeeeeeeeeeeeeeeeeeeeease.

You have to give devn-fd more options. You will have to give it a MAC address (AFAIK) and you will also want to use the hdlc option.

Thank you, cdm.

In " Utilities Reference" have 5 Options:

I don’t know, what is “the hdlc option”?

In the Reference writed:
“For example, you could use to connect to machines with a null-modem RS-232 serial cable. By using file-descriptor I/O to the serial devices, would implicitly use a serial driver and set up a logical network link.”

There “null-modem RS-232 serial cable” is:
2 ------ 3
3 ------ 2
5 ------ 5
total is 3 lines, right?

I attempt:
On Pc1:
io-net -dfd fd=/dev/ser1,mac=112233445566 -p[tcpip|pppoe|pppmgr]
mount -Tio-net

On Pc2
io-net -dfd fd=/dev/ser1,mac=112233445567 -p[tcpip|pppoe|pppmgr]
mount -Tio-net

the result is same.

kiss you, i love you.
everything is ok.
thank noc, thank cdm

answer from xtang. thx, again.

First of all, you need to do a “use /lib/dll/” to see if there is an option called “ahdlc”, if there is none, you are using an too old version, you will have to try the “use ip” part below.

[For Use]

First make sure the 2 serial set to proper paramters (baud rate, follow control), make sure you can “qtalk” each other through the serial link.

You need to start the with “fd”, “mac”, and “ahdlc” options

/sbin/io-net -d fd fd=/dev/ser1,ahdlc,mac=0x001122334455 -p qnet host=pc1

and give a different mac address/hostname to another pc. Make sure the first byte of MAC is 00.

[FOr use IP]
Use ppp to link the 2 pc. Then mount qnet with bind=ip.

mount -Tio-net -o bind=ip,resolve=dns

Just to avoid other potential problems, since you are only using a 3 wire serial connection, you want to make sure the software flow control is turned on, on both ends

$ stty +osflow +isflow < /dev/ser1

I don’t think that qnet cares what the fd is when you use it - it is up to you to make sure it works right.