trouble with linking boost


i downloaded boost and saved it on virtual box
i ran the command tar -xvf boost_1_53_0.tar it extracted the files.
i typed ./ and afterwards ./b2

…failed updating 14 targets…
…skipped 22 targets…
…updated 828 targets…

i copied all the built files over to windows directory.

on momentics ide i added
in the compiler

in the linker → extra library paths

linker → extra libraries

boost_filesystem boost_system

linker → extra object files

C:/boost/boost_1_53_0/stage/lib/ C:/boost/boost_1_53_0/stage/lib/
the project builds fine but when i run it i get the message

ldd:FATAL: Could not load library C:/boost/boost_1_53_0/stage/lib/

what am i missing?


Just a guess here.

By any chance did you create a “local” project.
That might explain the program’s looking for a shared object on a Windows File system.

Also, are you trying to run this on a QNX target, or locally?

i don’t know how to build in windows.
i tried to build in windows with visual studio command prompt but it doesn’t support toolset=qcc.
i tried to build it on the QNX target running in virtual box and it worked.

i am trying to run it on the QNX target.
i have a copy of the built files in /lib folder.
i also checked LB_LIBRARY_PATH it has the path to the /lib folder



is not a QNX file path it’s a Windows one.

I bet you configured the boost project under Windows and could not get it to compile (as you said happened) and then you copied it directly to QNX and built there. But you probably didn’t reconfigure for QNX so the paths remain set for Windows compilation/running.

Just fix the LB_LIBRARY_PATH so it points where is located on your target machine (pwd will give you the full path when you are in the folder where is located).


my set was fine apart from
choosing the option dynamic instead of static in extra libraries.