IPFilter for 6.2 NC

Is there a version of ipfilter that will work with 6.2 NC? I installed ipfilter 3.4.6, and it seems to startup correctly, but does not function. The newest version 3.4.27 will only work with PE/SE since it uses the tcpip-v6 stack.

Anyone found a solution?


Have you checked xtang’s ipfilter site?
I haven’t tried the binary and don’t know if it works for 6.2NC, but since the patched source is also on that site, it shouldn’t be too difficult to compile one yourself.
xtang might be able to give you more info.

That is the version I tried… Thanks for responding.

I am working with xtang now, I hope he can get it working. This has turned into a personal quest now :smiley:

Well I ended up reloading QNX 6.1… IPFilter works great now. All I can hope is that xtang will port a version for 6.2 NC :slight_smile: Maybe is I pay him money :slight_smile: Lots and lots of money :smiley:

For the most part all things that worked on 6.1 will work, without rebuilding, on 6.2. There may be some expcetions. So you could have just used the 6.1 package you are using on 6.2 without installing 6.1. ;) I think I posted a reply a couple of minutes ago on osnews.com about the same issue - perhaps to the same person?

I tried the 6.1 IPFilter package on 6.2, but too many odd things kept happening. Netmanager would hang everytime after loading ipfilter.so, xtang had me use external_arp as an option to npm.tcpip.so, and that made the interfaces unavailable. Once I loaded 6.1 with IPFilter, it came right up… no problems. So this might be one of those programs that just isn’t compatible. IPFilter is the only program that is keeping me from upgrading to 6.2 too. :angry:

Thanks for the response

Should work just fine. I know others that are using it without issue on 6.2.


I would love to know who they are, so I can find out what they are doing differently. Could you get me in contact with them?


Here is basically what is happening when I load IPFilter 3.4.6 on 6.2:

host config:
en0 - ne2000 - dhcp
en1 - el900 -

config file:
map en0 → 0/32 proxy port ftp ftp/tcp
map en0 → 0/32 portmap tcp/udp 20000:40000
map en0 → 0/32

I type:

#slay io-net
#io-net -d ne2000 -d el900 -p tcpip forward
#dhcp.client en0
#ifconfig en1
#mount -T io-net nfm-ipfilter.so
#ipnat -FC -f/etc/ipfd.conf
#ipf -y

At this point it behaves like it is not installed. ipfstat shows no stats. I can ping both interfaces from an internal host. Nothing appears to function.

Now if I load io-net like this: (as xtang suggested)

#io-net -d ne2000 -d el900 -p tcpip external_arp

I now get ipfstat information. I reports that it is passing packets, but from an internal host I get no response from en1. Externally I get no response from en0. From the host running IPFilter I cannot ping either of my own interfaces. And it hangs every time I run netmanager.

At first I thought I was configuring something wrong, but if I follow the same steps above with ipfilter 3.4.6 on 6.1 it works!

So my conclusion is either something has to be configured differently to get it to work on 6.2, or version 3.4.6 doesn’t work with 6.2.

I am open to any suggestions. I have another HD loaded with 6.2 ready to try anything.

Mark :smiley: