Momentics remote debugging problem

Hi, There,

I am a real-time system analyst in a University. I met a problem in Momentics remote debugging.

The problem is, I have 5 targets(with QCONN running) and 10 developing QNX machine with QNX 6.2.1 and Momentics. Right now, any developing QNX machines can connect with any targets. It causes problems, because anyone can connect to other group’s target machines (by adding a target in QDE target setting) and make their system/program crashing.

Is it possible to restrict the Momentics debugging access of the target boards with specific machine name, IP address or MAC address?

Best regards

No, but you could do it by segmenting the IP address or use ipfilter to filter out some IPs on target.

Thanks Mario.
Ipfilter on target might be a good idea. Can you tell me more about that? Should I put some file like “host.allow” in somewhere?

Not much sorry. I beleive it’s on the third party CD, the config file is a little more complexe then host.allow unfortunately (but much more powerfull)

I think you should be able to find wrappers on internet that should port easy on QNX6. These would be specified by editing the inetd.conf file (I have never done it myself)

Hi, Mario,

I found the ipfilter on the 3rd party CD and installed it on my desktop QNX PC. It works well. But when I tried to install it on my target. I met some problems. It seems have some relationship with io-net.

In fact, on my desktop QNX, I can launch Photon, use the SW installer to install the package. But on the target, I can only use FTP to download the files and lib. So I am not sure if I need to do something to help io-net to find the lib. (

I copied the ipf (excutable file) and from my desktop to target (a x86 SBC). Created a ipf.conf file.
But when I tried to use ‘mount -T io-net’. The system saied ‘Can’t mount / (type io-net), Possible reason: No such device or address’. (The same command works on my desktop QNX machine.) I checked my target system, the /dev/io-net is there.

Any suggestions.

Thanks in advance.

Hi, Mario, :smiley:

I fixed the problem. It caused by version conflicts. Some of my lib files are in old version.

Now the systems work as I expected.

Thank you very much for your suggestion.

Hi Unclesam!

I have the same problem with IPFilter that you’ve had. :unamused:

mount -T io-net

mount: Can’t mount / (type io-net)
mount: Possible reason: No such device or address

I read your post and searched for version conflicts. I found none. :confused:

Do you have or has anyone else any suggestions?


You best option is to provide a second ethernet card in each development box and directly connect each target machine to the local machine. I normally do this when developing myself, just a lot easier.

Hello cdm!

That won’t work. I really need to use ipfilter. This computer is designed to act as a router and thus it must implement a firewall. :exclamation:

Best regards,

denv - my answer was for the original poster. :slight_smile: