Samba client on QNX

Continuing my quest to access files on an AS/400 under QNX, I need to mount a Samba volume on QNX, but as root, I type:

bash-2.05a# /usr/sbin/fs-cifs /AS400 garry password
io_mount: No such process
/usr/sbin/fs-cifs: missing arguments, or all mount attempts failed.

I can mount it under the Mac OK.

Any ideas?



How did you become root? It looks like your path may be wrong. Either login as root, or do a ‘su -’. You shouldn’t need to explicitly path the fs-cifs since /usr/sbin should be in root’s path.

Hi Rick,
I tried su - and logging in as root, but same problem persists.

Is there any way to query the server for available mounts, the AS/400 can be a bit wierd with some network services, maybe QNX cannot communicate correctly with it. Does it matter that I’m on NC version of QNX?



You have to give the netbios name on the command line in addition to the IP (AFAIK).


Why isn’t the dash, as in su -, mentioned in the docs!? This is exactly why there is so many root users around.

Hmm, the plot thickens…

I can mount a Samba share on a Mac onto QNX no problem, using the exact same arguments except for the IP, username, and password. In fact I can mount the NFS share on the AS/400 onto the Mac, and access it from QNX via a Samba share on the Mac. So it seems that maybe the AS/400 is doing something a little different to the Mac.

I’ve tried NFS, Samba, and I cannot find anything available to mount FTP as a filesystem to get at files on an AS/400. I’d like to give fs-nfs3 a go as recommended by cdm, but although this page:

implies fs-nfs3 comes with NC version of QNX, it’s nowhere to be found.

I’m really stuck for ideas now, any suggestions very welcome…



I agree - I reported this as documentation bug to QNX.

You CAN mount FTP as a filesystem.
mritun has been working on this for a while and last I heard he got it working. Check the CVS at the project website:
I will wait for him for more comments, or you can probably PM him if you have any questions.