Apache + php for QNX

Is that what openqnx.com is running on?
Anywhere I can download a QNX binary version ?

The 3rd party disk has a compiled copy of apache and php.

openqnx.com doesn’t run on qnx, but qnxzone.com does and it uses apache and php.

rick is right that you should be able to find apach and php on the 3rd party disc. Or here is the version that runs qnxzone.com:

If you are running QNX 6.2.1, I am sure you will come back with more questions ;)

Thanks for the link, I dont have the third party cd as I am using QNX free.
What about enabling CGI and javascript on the server? Sorry this is the first time I use apache.

It doesn’t matter if you are using QNX NC (free), you can still download the 3rd party CD:

javascript is a client side thing, you don’t need to do anything on the server.

for CGI, just put in the cgi-bin directory and you are all set. If you want to have CGI in other directories, you will have to enable it in the httpd.conf file…

Great thanks, I’ll post the link to my outrageous site once it’s up :stuck_out_tongue:

I installed the apache from the third party CD and it works fine. I couldnt find php on that cd tho. I have also installed apache+php from the qnxzone link, but I couldnt get it to work for some reason. When I start the httpd, it doesnt give any error, but the process gets killed immediately. Any hints? I guess theres something wrong in httpd.conf

nothing is wrong, but I guess you are running QNX 6.2.1 which has a “bug”. If you check your apache’s error_log, I bet you will see something like “out of memory error”. no one knows how to fix that yet. the same binary works fine in 6.2.0 and earlier beta version of 6.2.1, but the final version of 6.2.1 doesn’t like it :frowning: I am hoping the upcoming QNX 6.3 will “fix” this “bug”. (hint, hint, any 6.3 beta tester reading this could try it :slight_smile:

The quick and dirty fix is to modify httpd.conf to comment out the php stuff, and you will be able to start apache fine. Once apache is running, you can modify httpd.conf to add back the php stuff, and do a “apachectl restart” which essentially send a SIGHUP signal to the httpd process to ask it to reload the config file. Bingo, you have php support now :slight_smile: