Hardware from the past

Hi there fellows.
Near the swamp, I found a motherboard that needs those extremely old and encumbrant hard disks. The bios recognizes modern hard disks correctly, except the diskspace. Qnx install gets the hard disk space right, and even installs with the “force partition install” option.But then it just won’t boot because the partition table is wrong. Is there any way to make qnx ignore the bios and boot with the correct disk space? Of course I installed the qnx boot loader for bioses before 96, but this motherboard is way older.
Getting a pci eide controller would probably solve the problem, but it definitely wouldn’t be worth the price.

How old? If you can install it, you can just boot from the CD and tell it to run from the harddisk. Or boot from a floppy.

Try to install QNX into a partition smaller than 2GB (or 8GB).

Pavol Kycina

I’ve already tried installing it on a partition below 500mb without any success.
This pc can’t boot from CD, and booting from floppy then CD gives a “can’t find pkg” error, only “force partition install” works. How can I make a boot floppy that ignores bios settings and points directly to the hard disk?
Thanks for your replies.

Can you pull the disk out and put it on another newer PC that can boot from CD, and install QNX there?
You can then put the disk back.

That’s one of the first things I tried. Gave the same error at boot.

Mandrill - what floppy are you booting? There is an install floppy and a boot floppy.

well, the only other choice is to do a no-CDROM install on the FAT.

I am using the floppy to install qnx on computers that “won’t boot from a cd”, the one that shows up when I put the QNX CD on a windows system.
I guess that must be the install floppy. Wheres the boot floppy?
I have tried booting a windows hard disk too, but it gives similar partition table errors at boot.

well, if you can even boot windows, maybe something else unrelated to QNX is wrong. you need to get that fixed first.

I was trying to get around the problem with QNX, but probably only getting an old hard disk with the right interface or a new IDE controller will work.