Problem with installing qnx.

I downloaded the QNX 6.2.1 iso image and i wanted to install qnx. Where I could enter the boot options i pressed F10 for a partition install. I can enter from which media i want to install qnx but then i get this error:

Unable to mount /cd//boot/fs/qnxbase.qfs as /qnxbase

Partition installation aborted!
Please remove the install floppy and CD, then reboot your machine.

I know that at this board someone had the same problem and asked for help. But he had two CD-Rom-Devices, which i don’t have. I only have an Zip-Drive, which i plugged out (when i didn’t do it or only disactivated it in BIOS I couldn’t enter from which media i wanted to install).
My Harddisk is at Primary Master and my Cdrom at secondary slave.

Sorry for my English and I hope you can help me.

I don’t think QNX support installing from a CD that is on slave. Try to put it on secondary master.

It’s okay with primary slave.

The IDE spec doesn’t allow for slave devices without a master and our IDE driver won’t drive them. So do either what noc or evanh said. ;)

I now did what you said, but now I get an error even earlier: qnx says something like: “unable to locate finstall”

Seems the CD isn’t mounted properly.
During boot, hit SPACE, F6, F6 to make it really verbose, and see what it says…

Maybe your CD drive is too old and unsupported, can you swap a newer CD drive to test?

I don’t think my CD drive is too old. Only ~2 years. It’s a burner… But I’ll try what you said

This may come off as a bit of a rant, but there is a reason for this, I’ve been trying to get the damn thing installed for the past 6 hours…

I’ts a newish PC 2Ghz P4, 1Gb DDR Memory, 1x80Gb Drive 1x20Gb, 1xDVD (16x) 1xCD-RW (32x/12x/48x) a Radeon 9700pro and an Adaptec USB2 & Firewire card, (it has USB on board, but I wanted USB2) OS is a fully patched version of XP Pro, the 80Gb is my OS drive the 20Gb is blank & unformatted.

My errors are exactly as stated below:

Either it can’t find /cd/boot/fs/qnxbase.qfs it cant locate finstall or it’s unable to find /.diskroot and unable to locate fs-pkg (from a boot floppy)

It will go through the entire deal of forcing a partition install, creating a partition, and installing a bootloader, but when it comes time to mount the drive, instant failure. If I let it attempt to boot normally from CD that fails too. Pressing F6 shows everything normal, scans for SCSI adapters, says it’s mounting /fs/cd0 on /dev/cd0 and then fails.

I’ve tried with the two drives on one channel 80gb master 20Gb slave and the burner as the master on the second chanmel, I’ve tried with the DVD as the slave on the second channel and the 20Gb as the master on the second.

I’ve tried all of the above with a boot floppy

I’ve tried with both QNX NC 6.2.1 and with the 440Mb ISO of 6.1.0. I’ve even tried the 66Mb ISO of 6.1.0 on a different brand of CD just to make sure. I can successfully copy off the files it can’t locate from the CD’s under XP

The irony of all this is that I actually own QNX4, it’s node locked to my old 486 back home, it has 32Mb of RAM a 4Gb IDE drive and a 4Gb SCSI disk hanging off an internal ZIP disk adapter, which QNX thinks is a SCSI adapter. It loads in two seconds from floppy drive seek to the login prompt, using the IDE’s MBR to boot, with the rest of the install on the SCII disk. I know how robust the damn thing is.

On top of all that I’m a geek of some 20 years standing, I built my first computer from a kit, and I’m a UNIX sysadmin by trade, but nothing I have done so far has made the slightest bit of difference, and it’s really, really REALLY beginning to piss me off!

To top it all off Hotmail isn’t taking mail from here, so I had to create another account using lycos… Argh!

So, in the unlikely event you ever get it working, let me know, I’m going to do something easier and install Linux on my Xbox instead.


Put the QNX installed HDD in the Primary-Master position. I believe it can boot to a second HDD but the default install won’t.

Have you tried hitting esc on the boot and running the image with no dma support? There is a slightly buggy VIA southbridge out there which can cause disk I/O problems like you are seeing (and it is a common southbridge). Once you are installed, there are ways to work around it.


Yeah, if I hit escape it just locks…

Tried that first :stuck_out_tongue:

I can’t put the “installed” disk as the primary, it’s blank, unformatted, and becuase of the CD issue, I can’t get past creating the partition. I appreciate what you’re saying, but I have uses for my PC, (like talking to my wife) that take precedence over running QNX, if it can’t install to a slave on the primary or a master on the second channel I have no use for it…


Can you try to disconnect the CDRW, and make the DVD as the secondary master ?
This is just for the installation, and once you get QNX installed you can reconnect CDRW.
I know the QNX installation sometimes have problems with more than one CD drive (CDRW or DVD).


There is only one drive connected at any one time. I’ll try hooking up the blank as the primary master and see if I can install that way, but I doubt it.

Is there any way anyone knows of to install to a blank drive from DOS or Windows? I’n running NTFS, so I can’t host the QNX partition in another drive…


I was talking about CD/CDRW/DVD drive, not hard drive.

I’ll give it a shot. I’m going to dismantle my mates computer and try and use his DVD :slight_smile:

Here’s an idea, can I boot with a demo floppy and setup the system that way? I can get the installer to create a QNX partition, and install a boot loader, it just bombs when it tries to access the CD after that. Can I access the CD from the demo? If I can, I can copy across the qnxbase.qfs right? Then what?

I’m determined this thing is not going to beat me, I didn’t get where I am now by letting the silicon wear the trousers… :wink:


You create a FAT partition on the second disk and install QNX on there:

BUT, you still need to resolve the CD issue, or else the installation will probably fail the same way.

I think if you have two CD/CDRW/DVD, QNX will mount them as /fs/cd0 and /fs/cd1. The installation process will blindly think your QNX CD is on /fs/cd0 and try to copy from there. What if your CD is actually inserted in /fs/cd1 ?

It doesn’t matter if you boot from CD or floppy, you will face the same /fs/cd0 and /fs/cd1 problem. You may be able to get around the problem by swapping the CD. But I still think it is better just to disconnect one and only leave one DVD drive.

I had exactly the same situation trying to install 6.2.1. on dual P800 (yes the chipset is realy buggy). I have tried every possible master/slave, primary/secondary combination of harddisk and CD (burner in fact) with no luck. After trying everyting what seemed logical I started to do unlogical things. I’v got another CD drive and … it installed like a charm! The only difference was that first CD drive was reported by BIOS as UDMA33 while second as PIO4. I found two other drives and again UDMA33 one failed not finding files while with PIO4 one everything worked fine. I would blame the buggy hardware, but matter of fact I have QNX4.2, Linux and W2k installed on the same machine from that UDMA33 CD and I had never problems with it.
Not sure if it helps but if you have another CD drive handy you may give it a try.

I managed to get it installed by using a very old DVD drive as a slave on the second channel, The install disk was the master. but in doing so I seem to have wiped a partition table :imp:

So I’m now on with recovering that, bum! As an aside it would appear that QNX will only read a CD on the same channel, I put my writer back up but on the primary channel, and QNX can’t see it.

How do you boot back to XP from the QNX bootloader btw, It asked me once which to load, and when I chose QNX, I could never go back…