Printing in LAN Printer ?

ping OK
I config my lpsrvr and printcap OK
I make a spool dir OK
But a go to print I have an error:
status: "waiting for queue to be enable on " ???

There are two printing system on QNX 4.

/etc/config/lpsrvr is the config file for “lpsrvr” server, and you use “lp” command to print to the printers defined in /etc/config/lpsrvr.

/etc/printcap is the config file for “lpd” server, and you use “lpr” command to print.

Your post seems to indicate you want the second one. Is your “lpd” running? are you using “lpr” to print? what does “lprq” say? you may need to use “lprc” to enable the printer…

The lpd is running OK, (The others printers printing ok)
I config the new printer equal the others printers ( I only change the name and the IP).

have you tried restart lpd?
what does “lprc status” say?
would “lprc enable all” help?

post your /etc/printcap

The others printers printing ok.
I restart lpsrvr and lpd.
All printers are config of same way:

the “rp” has to be called “raw” I believe.

I’m having a similar problem. frustratingly I got it working with a printer but the printer died (unrelated I hope). I can not get it to work with the printers replacement though no one seems to know what is different.

My printcap file is

I get “Couldn’t start daemon” when I try to start it through lprc.

I can see the same printer from a Win2Kbox and printing a test page via samba I get config info that looks like it matches this. Any one have any ideas?


Is lpd still running? If it isn’t, make sure it hasn’t left its lock file behind (/usr/spool/output/lpd.lock).

lpd is running. When I run lprq I get something like "can’t connect to "
Jobs submitted remain in the queue. I can print to the same server from win and Linux though the Linux box is using cups so I don’t have any comparable lpd config settings.