graphic driver for integrated Savage4?

:cry: I just bought a embedded PC with a system chip VIA VT8606 (PN133T Twister-T), the integrated video chipset is a savage 4 with ID : 0x5333, 0x8d01. I tried to use the driver, but it doesn’t work, I can only use the vesa driver. I need the accelerated features because my application is maily for DVD video playback, so I really need a driver that support harware accelaration for my graphics chipset. Can someone help me?



You can try starting the s3 driver by fooling the enum file with the ID of the S4. Don’t beleive that’s gonna work though (I beleive S3 and S4 aren’t compatible).

You could write a graphic driver using the DDK

You could change for supported hardware.

or try evanh’s enhanced vesa driver:

I gather the display is a mess or just plain blank when you tried to use ?

I note there is only two chip IDs listed in the supported hardware, you might be lucky and have it work when 6.3.0 is released.

Last option would be to talk to QSS and see if you can arrange for the driver to suit your variant.