Modem callback from QNX4.25 to Windows

Hi all,

My QNX 4.25 is configured to callback dialing (Caller=Windows, Callbacker = QNX 4.25). It works fine till modem connected to QNX4 hang up after entering caller ID. Windows don’t wait for callback. Windows interprets this as connection lose and wants to dial to QNX modem again (after 60 sec/manually immediately/cancel). QNX 4.25 modem dials to Windows.
So is there any way to work callback between Windows & QNX4.25? And how to configure it?
Thanx for any idea,


It seems to me this is a configuration issue on the Windows side. What Windows application are you using for dialing? Since you are doing callback from QNX, I would suggest using manual dialer on Windows. I used Hyperterminal a few years ago with QNX 4 callback, and manually doing ATDT… and then when QNX 4 calls back, I do “ATA” to answer it. When two modem connects, you can do the normal login stuff.

I’m using WindowsXP. After choosing connection it shows dialog box for entering phone number, user name, password… After dialing QNX asks me fo user ID. After entering ID, QNX closes connection/hangs up modem. But Windows don’t know why was connection closed so it interprets as not successfull connection and wants to dial again…
Do I need to use hyperterminal?

You should be able to set Windows XP to not retry . I don’t remember where but I’m confident I saw that option somewhere

What application do you use on Windows?
Are you doing a normal terminal connection, or PPP connection?


  • PPP connection (because I need remote access to IP network where QNX is connected),
    => HyperTerminal or something like this will not help me,
    => mainly I need to connect to QNX throught phindows…
  • in Windows XP I has entered its IP for this connection (setted throught connection dialog).

Any Idea?


Ok, but I need after setting that to constrain Win XP to wait for call.
And why Win&Win modem callback connection works correctly and Win&QNX not?

click “Properties” on that dialog box, and you will get a “Properties” dialog. Then click “Security” tab and check the “Show terminal window” under Interactive logon and scripting.

this way, you will be able to get a terminal and “see” the login process. when you “see” QNX is ringing back, just type ATA to answer it.


Nice, but this must be automated as you can see it between Win & Win callback. That is for our customer, therefore there can’t be any user intervention. After callback there is needed to be able to connect to Photon (to QNX) via Phindows (from Windows)!
And what you wrote don’t works… It shows terminal but after dialing to QNX modem (by clicking OK button in terminal dialog box) you need to cancel initial connection and start connection again! And after that you are not able to connect via Phindows! I thing that doing it this way QNX don’t assign IP for my Win PC, so I can’t use Phindows…

automation aside, my suggestion was just to make sure you can get it work manually. Once that’s working, you can probably just write a dialup script:

waitfor “RING”
transmit “ATA”

You can check Microsoft document or do Google search to find out how to enable and write dialup script.