NFS Server files missing


I’m trying to start an NFS server on my Neutrino system so that I can mount the filesystem from my Win XP box (and do nightly backups on the corporate servers).

I went to the following link:

which seems to describe the process very well.

However when I tried to follow the steps on my system I ran into a problem.

The portmap call ran just fine.

But nfsd and mountd both are missing. I tried doing a ‘find’ command for both from the root directory but was unable to find either one.

So I ran the package manager under Photon looking for a package that would seem to contain the missing files. Alas I was unable to see any packages that looked like they were the right ones.

So does anyone know which package I need to install or where I might find these missing files.

Lastly, does anyone know if NFS mounting from Win XP works well? I assume so but was curious from anyone who knew. Will I need any special programs on the XP side to handle logging into QNX?



I have it on my system (in /usr/sbin/nfsd). Do you have the NC version - perhaps it doesn’t include it. It is defintely there on 6.2.1PE.

I though it was Nfsd.

Another option is to use samba ( on 3rd party CD) a little tricky to setup but better then NFS (plus you don’t need to install NFS on the windows machine)

Do you use the free or paid version of QNX 6? check this thread for some differences:

mario, Nfsd is the QNX 4’s nfs server.


How do I tell if I am using a purchased or free version of Neutrino? I just installed what I was given at my company.


What’s the 3rd party CD and how do I obtain it? I’ll try to get samba going if it means I can avoid NFS under Windows.

Thanks for the replies,


On my install, I’ve found two notible places of ID:

The Licence banner that appears very early in the boot process, ie: before “Detecting EIDE devices…” clearly says that it’s for Non-Commercial use only.

Also, the first topic in the contents of the help docs is headed up, “QNX Momentics Non-Commercial, Documentation Roadmap”

I haven’t done a re-boot but I haven’t noticed this message and I have done enough that I think it would have stuck out at me.

I just checked the help docs with the help viewer. I dont have any content labelled anything like what you see. So I think I must have a purchased copy which would only make sense for a corporation.

I just wonder if there was something missing on my CD image or something not installed. I did my installed from an .iso image, not an actual CD-Rom. The .iso image is supposedly from a QNX CD-Rom but perhaps something is missing?


I took a chance that Mario was right and I checked and lo and behold I DO have an /etc/sbin/Nfsd not nfsd as the article I linked to mentioned. However, I don’t have a mountd or Mountd command.

I checked out the help doc’s on Nfsd and created a /etc/exports file with just a ‘/’ in it for now to test. I then ran Nfsd -t & and all went well (or at least Nfsd parsed and started and didn’t exit).

So far so good. But now how do I do a Mountd/mountd without that command? The Nfsd docs seem to indicate that Nfsd handles incoming mount requests. If so, how and how can I send such a request from my XP box and how does Nfsd know if the request is coming on a privileged port?

Also the docs mention creating an /etc/nfsstart file which I did so that Nfsd will be autostarted on boot. However I don’t even have an /etc/netstart file so my /etc/nfsstart file is never going to be called. Is there a way to generate a default /etc/netstart or should I already have had one?

I wish the doc’s included actual examples of how to make this work.


Can you please post “uname -a” ? Just curious which version of QNX you are using.

QNX localhost 6.00 2000/10/17 -14:59:25edt x86pc x86

We are not using the latest patch (6.02 I think it is) because management didn’t want to tinker with what was working already.

Does this help?


Ouch - The latest released version is 6.2.1B and 6.3.0 is currently in beta.

I believe nfsd services both nfs and mount requests - I suspect Nfsd would be the same.

Been a while since I played with 6.0 - 3 years or so. Try starting nfsd in /etc/rc.d/rc.local - create the file if it doesn’t exist.

There have been a lot of changes/bug fixes, etc since 6.0. Certainly C++ is not too standard on that version - it is prior to the dinkum libs. On the other hand, if it works for you, go for it. :slight_smile:

Yes. I’ve noticed how out of date we are. But this project started about 3 or so years ago and is almost finished and ready for launch (medical industry takes time). I’d love to upgrade and change C++ libs but if I did and ANYTHING went wrong management would hang me (I only recently started here) because they want to start selling and recouping engineering costs.

You’ll have to bear with me on the mounting part. I’ve never set up the server side of NFS before. So I don’t understand what you mean by Nsfd will hande the mount requests. Do you mean I have to issue a request on the QNX side or does the client do that on the connection side when they connect and mount to ‘/’? I’m not sure what else I have to do after I launch Nsfd.

I’ll try starting it via the file you suggest and see how that works on my next server re-boot.

I’m also downloading the 3rd party CD to grab Samba (hope it works on this version) from Marios suggestion to see if I can get that to work.


I do a lot of consulting in the medical device industry and am very familiar with the process and problem. :slight_smile:

I haven’t played with an nfs server on the qnx side for quite a while, but I suspect all you need is portmap and nfsd. When I do ‘use nfsd’, I get:

nfsd    NFS (ver 2 and ver 3) and MOUNT (ver 1 and ver 3) server

nfsd [-t] [-f ] [-h ] [-x ] [-o] [-s] [-P]
     -t         Service TCP transport
     -f n       Open file cache size    (default= 16)
     -h n       File handle cache size  (default= 200)
     -x n       XID cache size          (default= 16)
     -P         Parse check exports file
     -o nfsvers=2       Start NFS ver 2 service only.
     -s n       Flush cache every idle n seconds (defaut= 5)

Since it says it serves both NFS and MOUNT protocols, I suspect that is all you need.

And this is QNX, so you don’t need to reboot to try this. :slight_smile:


I know you don’t need to re-boot to test this. But you do need to re-boot to test if the automated scripts that run at startup are working correctly. I’m not so worried about that part as I can fix it later. Right now I just launch Nfsd as a background task.

Anyway, my use Nsfd basically says it’s NFS ver 2 and Mount ver 1 server.

So I am sure it does handle Mount requests.

My question is, now that I have Nsfd running in the background, how do I test that it’s working correctly? Do I just have to try to connect to the QNX machine from a windows box using WinNfs? I guess what I’m asking is, when does Nsfd mount the ‘/’ drive that I specificed in the etc/exports file or has it already done so and is now just waiting for incoming client requests?

One another note. I grabbed the 3rd Party CD-Rom iso file and put it on a CD in my CD-Rom drive. I pointed my package manager to look in /fs/cd0/repository. It did so and calls the package ‘QSSL’s Unsupported Repository’ and several packages show up as being available. However, not all do. For example I can see by ls’ing into the repository directory that samba is in there. But it does not show up on my list of packages to install (which is very small compared to the number of files in the repository directory). Any idea what might be causing that? Could it be a OS version issue someplace?



You also may want to check if you have a pcnfsd or similar program - apparently it is needed for environments which don’t have user/password systems. It was originally needed for DOS, but I am not sure if it is needed for Windows.

So assuming you started portmap first, then Nfsd, you should be able to mount the exported file. You could always try it from QNX first - try mounting your own exported files:

fs-nfs2 127.1:/exported_dir /mount_point

and see if that works, before you add Windows to the mix.

I would not be surprised if you can’t find any repos which still work with QNX6.0. The format changed somewhere along the way and most of the repos are at the 6.2 level.
A large part of the problem is the libc changed in 6.1, which makes 6.0 unable to run pretty much any current version software. You could always try to download samba as source from and use that.

The easiest test is “rpcinfo -p”, and you should see both mount/nfs service is ready.
If you still want to test for sure, the use the “fs-nfs2” like rick gave. You probably
need a -t somewhere since you seems started Nfsd with -t (tcp mode?).

I don’t know XP support NFS by default though. I know MS have something called
“Unix Service Package” (?) but don’t think it comes from XP by default. You probalby
need some 3rd party Windows Software to mount the QNX machine.