Gaim .72

I recently grabbed the gaim .72 port from either cdm’s or Kinners’ repository, it runs fine, except…text doesn’t seem to show up anywhere on the UI. The textboxes and dropdown boxes are also, very small and thin. I have installed all the fonts and libraries I found, but to no avail. I’ll see if I can fix anything I am missing tonight, but any idea’s would be grand.


one thing you can try is to download xfree86 from … z?download

as root,
cd /
tar zxf xf86-4301-qnx6-bin.tar.gz

then reboot and see …

I have 4.2 activated and 4.3 deactivated. With 4.3 when I run XPhoton, and then vncviewer, I get unresolved symbol errors. So, I stuck with 4.2 to keep vncviewer and it just works even though I hear it was compiled against 4.3 so I dunno what’s going on.

The URL I gave has a different xfree 86 4.3 from your copy. That one is compatible with vncviewer, so don’t worry :slight_smile:
By the way, it installs into a different directory (/usr/X11R6) so it won’t affect whatever you have installed (4.2 or 4.3) in /opt/X11R6.

Well, I grabbed and installed it, but gaim still doesn’t show fonts, and everything is still small. I’ll be grabbing a new set of QT libraries and see if that helps.

I think Gaim is using GTk2 for the gui.

Seems I spoke too soon. The next day after powering up my laptop, vncviewer did not work with both XPhoton calling XFree86 4.2.0 and 4.3 with a ReadFileToPixmap error and unable to resolve symbols. I also recall installing GTK2, and since the actual UI works, it can’t be that problem. While I’m talking about X, do any of you use xchat, cause it keeps dying out on me right as I ‘/server foo’ and crashes X too.


The fact that you are still getting the unresolved symbols for vncviewer means you are NOT running the XFree 86 4.3 from

Do you have a /usr/X11R6 directory? Have you disabled XFree86 packages? (check if you still have /opt/X11R6 directory). Once you have everything good, you should do a reboot, and check again to make sure it is really good ;)

Hrm. I still do have the QNX Online package installed and activated. Is there a way to deactivate them, without uninstalling ? I still do have ‘/opt/X11R6/’ existing and the tarball from the sf openqnx page uncompressed in /usr/X11R6, yes. I created a symlink that just pointed to /usr/X11R6/bin/XPhoton instead of removing the whole /opt/ X11R6 package. I had it running with 4.3 as soon as I installed it, I tested gaim, and it still didn’t fix anything, rebooted, vncviewer gave up those errors, and gaim still had choppy/unuseable UI.

I guess you want to make sure the new XFree86 does fix your problem before you want to uninstall/deactivate the other XFree86 packages.

Here is a quick test:

open a photon terminal
slay XPhoton #kill the xphoton
echo $LD_LIBRARY_PATH #check the existing value
echo $LD_LIBRARY_PATH #check again, make sure the /usr/X11R6 is at the beginning.
export PATH=/usr/X11R6/bin:$PATH
/usr/X11R6/bin/XPhoton #start xphoton again.

now try your vncviewer and gaim again…

Well, that fixed vncviewer with 4.3, thanks. but Gaim still has funky-ness to it, heh.

edit: It’s a GTK font problem, I ran gtk-demo and it also does not display any text, and gives out a Couldn’t load font Verdana 9, falling back to Sans 9 error. I’ll probably take it up with the Gimp/GTK kids and see if I can get help. Thanks!

maybe Kinners’ gtk2 post install script failed?
What does “ls -l /etc/fonts /etc/pango /etc/gtk-2.0” say?

They show up, each contaning, respectivly :

/etc/fonts: fonts.conf, fonts.dtd and local.conf
/etc/gtk-2.0: gdk-pixbuf.loaders and gtk-immodules
/etc/pango: pango.modules and pangox.aliases.

I wanted to see if any of those files are 0 byte. “ls -l” should show that.

Well, in that case; gtk-immodules and pango.modules are both 0 bytes.

Here you go :slight_smile:

Apparently the post install script failed. Kinners may be able to tell you exactly what that script does, but in the meantime, you could try:

export LD_LIBRARY_PATH=/usr/X11R6/lib:/opt/lib:/usr/lib
/opt/bin/pango-querymodules > /etc/pango/pango.modules
/opt/bin/gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
/opt/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

Arrrsome! It works now. I praise you, and grovel at your feet. Now if the MSN plugin would stop gaim from dumping core, I’d be in the monnaie, or wait until .75 gets ported or something ;)