Not able to install QNX 6.2.1 NC

Hello everybody,

First of all, I must confess that I’m a complete QNX-newbie. Perhaps, there is a simple solution to the problem I have, which I don’t see.

Now my problem:

I repartitioned my disk (37 GB) to install QNX. Currently, I’m running Windows 2000 and BeOS 5.0 on the first two pr. partitions. I intended to install QNX on the third. The fourth is a extended part. with 3 logical ones in it. (Yes, one could say I’m a partition freak ;-) but that’s reserved space for a Linux installation)

However, each time I’ve tried to install QNX it has failed. If I boot from the CD, I get a message about no QNX 6.1 or higher partition to be found. I also tried to use the force partition install (F10) option, but then, after creating a QNX partition, it says: “unable to mount /cd//boot/fs/qnxbase.qfs as /qnxbase” (and yes, there really are 2 slashes).

It seemed to me there’s something wrong with the cd, but if I run it in Virtual PC 2004, everything is ok, and I can easily install it.

At the moment, I’me quite puzzled… could there be something wrong with the bios-settings or the hd? or is it some kind of known behaviour?

Thanks a lot and greetings

the error seems to indicate there are some problems with CDROM drive. Check the following two threads and see if they help:

Unsupported IDE controller, ie: nforce/nforce2 southbridges, can produce this result too.

thanks a lot. I managed to install QNX now using my other cd-drive.

But I’ve got another problem now: I can access to neither cd-drive. In /fs, there is just a broken link to cd0. Do I have to mount them manually?

That can be normal, a broken link occurs if there is no disc present or the fs on the disc is unknown.