io-net not in /dev

I created a custom OS that now boots to a microdrive. Seems to run okay, but the problem I am having now is that in my sysinit, I run the following:

io-net -d smc9000 -p tcpip
inetd &

I don’t see io-net in my dev directory, or running in processes. So I looked at help for smc9000 and it looks like you have to specify the mac address in the io-net line. So I try to use ifconfig, but I keep getting an error that says

ifconfig: getifaddrs: Address family not supported by protocol family

Is there anything obvious that I am missing here.


I seem to remember only the tiny stack supports if=en0… options, so you will need to do
-p ttcpip …

check: … o-net.html

for tiny stack: …

for full stack: …

If io-net doesn’t show in /dev something must be missing. Even if smc9000 was missing argument or had wrong argument io-net should still be running. As a matter of fact starting io-net on its own is enough to create /dev/io-net. Try that first. Also try staring slogger, maybe you’ll see some error code in there.

slay io-net
Are you already doing that?

Thanks for the suggestions. I had been using an Ampro 486 (100MHz) board and wasn’t having much luck overall. When I used a newer board (Littleboard 700), I could see io-net in the dev directory and I used ifconfig to set the IP and Netmask and was able to FTP.

My goal is to start this stuff in my sysinit file. When I put the io-net,ifconfig,route commands in there, I get a similar error to the one explained above:

ifconfig: socket: Address family not supported by protocol family

Could this mean it is not seeing some libraries? I am able to start it manually from the command prompt. I do an
export PATH=/proc/boot:/bin:/usr/bin:/sbin:/usr/sbin
export LD_LIBRARY_PATH=/proc/boot:/lib:/lib/dll:/usr/lib

at the beggining of sysinit, but pretty much comment everything else out except for the addition of my network config. stuff.


post your sysinit.
I have a feeling you made a typo in there.
were you starting io-net with -ptcpip or -pttcpip (two tt’s).

We figured out what was going on. In our sysinit we were not doing a waitfor after the io-net command. So we tried “waitfor /dev/io-net/en0” and it still didn’t work. Then we tried “waitfor /dev/socket” as shown below and it worked.

io-net -d speedo -p tcpip
waitfor /dev/socket
ifconfig en0 netmask
route add defualt
inetd &