Eclipse JDT local history not working

I am wondering if anyone out there is using the Eclipse JDT, and successfully using “restore from local history”. Everything in the JDT seems to work for me, except this. Does it work on other platforms (I don’t have another platform with enough Horsepower to run eclipse besides QNX).

JDT? I haven’t heard of that. Maybe you are talking about CDT?
If that’s the case, your best bet is to use news:// is leading that project and monitoring that group.

One of the issues you will hit when using the JDT (noc: Java Development Toolkit, always been part of Eclipse) is the filename limit with qnx4fs in versions of QNX6 up to 6.2.0. So, the only real alternative you have right now is to use an ext2 filesystem.

I should have an e2fsprog package at today/tomorrow. Check there for it. You can use that format and setup an ext2 filesystem-in-a-file and mount it from your qnx4fs.

This is lame I know, and yes, it should be fixed in the next release of QNX.

Before you go off on the ext2 path…can you view your local history for a file? Using the Compare option from the Package Explorer view on a file?

Thanks for the help (sorry it took so long to respond).

I tried comparing with local history, and that worked. The strange thing is that replace from local history now works also (I am wondering if maybe it works only after first doing a compare from local history).

Anyway if it shows up again, I have some ideas on where to look.

Are you saying that ext2 will be supported better in the next qnx patch, or that qnx4fs will now support more than 48 characters.

(the only thing I have really had problems with the 48 char limit on is doxygen - so I already have an ext2 part.).

Personally, I think if ext2 was supported well, then why the heck re-invent the wheel, keep qnx4fs for embedded devices and use ext2, as the development time fs.

It will have longer filenames.