nForce2 Audio + QNX Momentics

I have nForce2 audio with Momentics. It doesn’t work ;) Under Linux, I run it as an i8x0. QNX… no dice. Absolutely no messages when I run io-audio, but media player reports no sound devices. Any ideas?

More specs as needed…


Buy a cheap sound card, the CMedia 8738 controller works a treat:

Blah! OK, how about this… I doubt QNX makes their audio driver open source. So, how about a port? Would a BSD/Linux license get the job done? And if so, what is required to port to QNX?

I want to be brave, be a programmer ;)

There is an SDK to write audrio driver. A port isn’t really possible since architecture is different then Linux.

If you can get the source to the nforce2 driver (are you sure it’s really nforce audio chip cause i’m surprise i8x0 works with it).

Problem with all Nvidia stuff is they don’t provide spec or source code so everything is based on hacking and reverse enginering.

Yep, the DDK is all there with your default installation in /usr/src/ddk-6.2.1/audio/src/ with a working example in /usr/src/ddk-6.2.1/audio/src/hardware/deva/ctrl/audiopci

And the help docs have an audio DDK section.

If you do get some sources for nVidia stuff, you’ll be the toast of many a user. :slight_smile:

Hmm, no DDK in that directory for me. Momentics (free version, if that matters)

Checked on QNX’s online repository and didn’t find it. Is it around there somewhere? If so, what is the package name?

Caveat lector (let the reader beware!) I may not actually be using nvaudio. I just remember that on my motherboard, an Asus A7N8X-Deluxe, the sound under linux is provided by I8x0 drivers. I always thought that sound was provided by nvidia. So I might be wrong!

I am sure this will be nowhere near trival. But I am interested in at least trying. If I don’t get it, well, perhaps I will come out learning more about programming then when I went in ;)

You prolly have a nVidia northbridge and an Intel southbridge. If this is the case then you may be able to use for a sound driver.

As for the lack of files in your installation, please complete your install by popping the cd back in the drive and starting Installer then follow you nose.

Bah, sorry to be such a noob here ;( I put the CD in, and the only two packages on /fs/cd0/repository are QNX Installer and QNX Updater, both installed. Is that the wrong path?

evanh, you may be correct. How would I go about using the correct driver? I have tried everything… io-audio -vv -d i8x0 gives no output, and sound still doesn’t work. Am I missing something?

pci -k gives me this interesting output, FWIW:
Class = Multimedia (Audio)
Vendor ID = 10deh, Nvidia Corporation
Device ID = 6bh, Unknown Unknown
PCI index = 0h
PCI Mem Address = d6000000h enabled
PCI Int Pin = INT A
Interrupt line = 5

Class = Multimedia (Audio)
Vendor ID = 10deh, Nvidia Corporation
Device ID = 6ah, Unknown Unknown
PCI index = 0h
PCI IO Address = e400h enabled
PCI IO Address = d000h enabled
PCI Mem Address = d6080000h enabled
PCI Int Pin = INT A
Interrupt line = 11

Put the QNX CD back in the CD drive, and click the Installer (that’s an icon on your Photon shelf ). The installer will read the content of the CD and present you with a list of available software. You can then pick and install “QNX Momentics for x86”. This should get you /usr/src.